Help needed with failed HAOS install on laptop

I posted yesterday about my HA system plan. After hearing from a few members that the plan was OK, I pulled the trigger on the install.

Flashed the HAOS for Generic x86-64 on my new SSD using Balena Etcher. Got the “flash successful” message. Removed the old laptop HDD and installed the new SSD. Made BIOS changes to enable UEFI boot and set the new SSD as first boot device. Connected an ethernet cable into my LAN.

When I turned the system on, I never got the Home Assistant welcome screen … only a blinking (command line?) curser in the upper left corner of the display. Tried logging into the HA system from a browser on my desktop machine at both homeassistant.local:8123 and homeassistant:8123 as suggested in Installation Help documentation. Nothing…

Any ideas how to proceed would be greatly appreciated.

Karl

HA System: dedicated Asus U52F laptop, 2.5GHz dual core i3 processor, 4GB RAM, 240GB Crucial SSD.

Your life will be easier if you just install ubuntu, install docker, install portainer, run ha in docker

Your install is not supported for HAOS so that will create problems and confusion for you

Portainer is docker UI and has log that you can read and help see what happening when stuff not work

Debian or other Linux works also
There is Linux UI, cockpit, that may also be useful for server management

EDIT
I would expect a “no is” found message if it didn’t boot OS. For example, if you remove hard drive do you get same flashing prompt?

Thanks for the comments. I don’t follow your statement

I thought my install was a fully supported, recommended one. Please elaborate.

Karl

Then he misses everything supervisor provides.

My mistake
I didn’t realize generic x86 was supported

You should verify OS is booting properly
I’d expect to get some message if OS not boot or nothing running so the flashing prompt tells me OS booting but something is hanging or it’s actually doing something in background but not displaying to you.

Does the machine get an ip address?

Can you ping it?

Is port 8123 open - Use nmap

How long did you wait before you tried to connect on port 8123?

Did you try the ip address as opposed to homeassistant.local?

2 Likes

This is expected. You’re welcome to install HAOS on a laptop obviously but the operating system has no GUI. A blinking cursor is all you will ever see when you lift the lid of that laptop as long as HAOS is installed.

That isn’t expected. It’s possible that is caused by reasons outside of HAOS’s control though. Those urls work via mdns and llmnr and not all devices understand those technologies.

Find out the ip address of your laptop on your network. You should be able to see this in your router (or by using the terminal when you lift the lid if you’re more comfortable in the command line). Once you figure it out go to your desktop and enter http://<ip address>:8123.

If that doesn’t work then something is wrong with HAOS and you’ll need to track down logs. If that does work then your desktop is unable to use the mdns or llmnr names. So you’ll either need to debug that on your network/machine, use the ip address instead or figure out an alternate way to give it a local domain name (like in your router perhaps or a local DNS server).

1 Like

Whew! That’s what I have been running for a couple of years.

Is this the image you used?

The welcome screen takes a few minutes the first time. Hassio will take a few minutes for everything to download/update.

Do you get a login prompt when you hit return?

Still running down my install issues. Responding to some of the replies …

stevemann … I did use the generic x86-64 install image for the HA OS

CentralCommand … The HA welcome screen never came up on the laptop, only the blinking curser. I could not enter any text from the laptop keyboard. I couldn’t log into the HA laptop from my desktop.

nickrout … I’ve waited hours for the home screen. I’ve power cycled a few times. No change to the curser. No welcome screen. Can’t get an IP address of the laptop. Logged into my router looking for a new wired client, since I was connected via ethernet cable. No new wired device showing up.

thanks,
Karl

Download the image again and flash the SSD again.

Or

Flash Ubuntu Desktop on a USB Stick. Select try, not install. Then flash the SSD with balenaEtcher from Ubuntu.

How was the SSD formatted? It shouldn’t make any difference since you are flashing the image, but you might want to format it as FAT32.