Help needed with frigate and cpu

hey all for a bit now my frigate has been suddenly eating at my cpu and i have no clue why or how to stop it any help is appreciated

I noticed it last night too. I ended up shutting down the add-on overnight and did an HA restart this morning after a system update (Supervisor maybe…don’t remember). Seems to be down now, but still reading odd:

The release notes for 0.13.0 did mention a potential increase in CPU utilization:

1 Like

So I changed the detector from CPU to OpenVINO and the usage dropped even more (I do have GPU acceleration setup). CPU usage is back to happy:

1 Like

What integration is that HA Stats?

System Monitor


how did you do this?

Which part…changing the detector or using GPU acceleration or both?

1 Like

everything you did to reduce the usage haha

mine is still running at an extreme rate

GPU acceleration depends on the hardware that you have available. I’m using the iGPU from the Intel CPU installed in my “server.” OpenVINO can use a few options. For my specific config, this is what I added to the Frigate config:

    type: openvino
    device: AUTO
      path: /openvino-model/ssdlite_mobilenet_v2.xml

  width: 300
  height: 300
  input_tensor: nhwc
  input_pixel_format: bgr
  labelmap_path: /openvino-model/coco_91cl_bkgr.txt

But, I will admit, I do nothing fancy with Frigate. I have it setup to do constant recording for 24 hours and 10 days of event storage. No custom object recognition and what-not.

1 Like

well nothing changed but i suppose i am supposed to do a bit more then just copy and pasting that into the config

i know i have activated some acceleration in the bios of the mini pc when i migrated but i dont know any specifics

Did you restart Frigate?

1 Like

yep save config and restarted

ah nevermind! just took a second!!

seems to be back to sensible levels thanks!


1 Like