Help needed with Siri problem (WAF at high risk!)

Siri control of all my HASSIO devices was working perfectly until a few months ago when suddenly something changed. Now, when I am outside my LAN (after a few hours, connected via LTE) and request Siri to do anything from either my iPhone or Apple Watch, here’s what happens:

Getting in Touch…
One Moment…
I’m Sorry, but I didn’t hear back from your devices.

Now, here’s the strange part: better than 50% of the time, the request actually worked but was reported as failed. Then, if I ask a second time, the request works 100% of the time immediately and reports back as such. Then, any requests will continue to work perfectly for quite some time. The trouble is only on the first request. It’s as if the Homekit=>HASSIO connection times out and thus the first ask always fails but re-esatblishes the connection for subsequent requests.

Here’s my setup:

HASSIO on Raspi 3 (updated to current)
Duck DNS/Let’s Encrypt
Apple TV 4K for Homekit Hub.
Google Wifi system

Here’s what I’ve tried so far:

  1. Deleted homekit.state file and re-paired HASSIO with apple tv
  2. signed out/back in to iCloud on all apple devices
  3. filtered HomeKit yaml to include one entity only (a desk light) for testing
  4. connected HASSIO raspi and appletv via ethernet to same switch (which is plugged into primary Google Wifi puck).

I am very hopeful someone here can direct me towards a solution or actions for further troubleshooting. The WAF decreased dramatically when this broke, especially since we bought Apple Watches to control the house and Siri is her primary interface to HassIO. If I don’t fix this very soon, her confidence in the entire HA system is at risk!

Thank you in advance for your help.