Help! No HA Access After U[date

Hi all

Panicking a little here…

I have a script that I run to perform updates when new releases of HA come out.

Its been fine for 12 months, but today it has fallen over and now I can’t access HA and it doesn’t seem to be running at all.

I run HA in a container (Portainer) and the script reported the network mode was incompatible (was host). Was weird, but thought maybe the update ment it should be change. I changed to “Bridge” and the update completed, but I can’t access HA.

I have subsequently changed it back to Host and restarted the container with no change in behaviour.

docker compose:

    container_name: homeassistant
    image: ""
      - /opt/homeassistant/config:/config
      - /etc/localtime:/etc/localtime:ro
      - /run/dbus:/run/dbus:ro #Bluetooth. Doesn't Work
      - /dev/ttyACM0:/dev/ttyACM0 #zigbee USB
      - /dev/sda5:/dev/sda5 #UPS. Maybe?
    restart: unless-stopped
    privileged: true
    network_mode: host
      - "443:443"

update script

apt update
apt full-upgrade -y
apt autoremove -y

cd /opt/
docker-compose pull
docker-compose up -d
docker image prune -af
docker volume prune -f

I can ssh in to the server itself, but can’t get a response from HA

Don’t use ports:

1 Like

Solved!!! Thank you so much!

Why has this compose worked for me for so long but fallen over now?

The bigger mystery is why you used it in the first place.

1 Like

Sorry to resurrect, but I am still baffled by this.

I have used Ports: for two years in the docker compose file and been able to access HA externally.
What has changed in the past few months to make the Ports: option not viable?
I’m really scratching my head now as to how I can access my HA intance externally.

I don’t know, but host networking has always been prescribed, and if you have host neworking, port is redundant.

Maybe docker has changed how it interprets the broken situation with both ports and host set.