Help please - HACS failed to load - no idea how to debug

Been running HA for a year or so - doing some updating this morning of stuff loaded via HACS and now I’m getting this: image

I’ve checked the logs but not really any the wiser - here’s the log flagged by the check the logs link

This error originated from a custom integration.

Logger: homeassistant.config_entries
Source: custom_components/hacs/
Integration: HACS (documentation, issues)
First occurred: 11:46:54 (1 occurrences)
Last logged: 11:46:54

Error setting up entry for hacs
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 387, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/config/custom_components/hacs/", line 220, in async_setup_entry
    setup_result = await async_initialize_integration(hass=hass, config_entry=config_entry)
  File "/config/custom_components/hacs/", line 206, in async_initialize_integration
    await async_try_startup()
  File "/config/custom_components/hacs/", line 193, in async_try_startup
    startup_result = await async_startup()
  File "/config/custom_components/hacs/", line 171, in async_startup
AttributeError: 'ConfigEntries' object has no attribute 'async_setup_platforms'

I’m also seeing this in HACS itself

I did update the custom template-entity-row lovelace element - it seems to be working fine but not aware I’ve done anything else lovelace related.

I’ve restarted but same error.

All ideas welcomed - thanks

OK - solved.
HACS (which failed to set up?) showed there was a HACS update available.

Did the update restarted and all is well. Phew!

1 Like

lol thanks had the same issue, just had to update hacs

Same problem, but no updates available… :frowning:

1 Like

My next step would have been to delete and reinstall the HACS integration - might be worth a try?

If not probably best to open a new thread - this one is marked solved so might not get much attention.

Good Luck

1 Like

Same problem here, and also with the Meteobridge integration. And both show needing updates. There needs to be a better way to notify about integration updates than just dying with “failed to load”

1 Like

There is, with update entities. You can enable these with HACS experimental features.

1 Like