Help please! - Raspberry Pi Zero setup

I’m trying to setup on a raspberry pi zero. I know Pi3 is recommended but I specifically need to use the pi Zero due to hardware connection setup in my house and the fact that I often take my Pi3 out of the house.

I’ve written the Pi Zero img file to an SD and setup the USB stick. I don’t have a USB hub and so I’ve had to try the insall, wait 20mins, knock the power off and then switch the USB stick for a WiFi dongle. Unsurprisingly this has not worked.

For those that understand the install process better than I do - should this work? Maybe I should have waited a bit longer before swapping the USB stick, or will the install not work if you don’t have the USB stick and WiFi available for all of the install process?


Just wondering if you ever solved this problem as I have just got the same wall!
Followed all the steps and can connect via LAN no probs but WiFi proves illusive.
Please let me know,

Hi @kevroxldn unfortunately I wasn’t able to resolve the problem. I ended up installing raspbian on the Pi zero and then hassio on a RPi2. I got the two talking to each other using MQTT messages.

Hopefully someone in the know will pick up on this.

Best of luck.

Hi @AJStubbsy,
I’m still trying to solve it. If I have any success, I’ll shout it from the highest forum! If not I’ll have to buy a RPi 2 or 3 and admit defeat.

Thanks for the update.

1 Like

I got it in the end, the speck of dust on my screen was actually an apostrophe sitting before the network folder
Works fine now but I picked up a few tips along the way. If there are problems with the USB method, try using Linux to write the file in the boot partition, seems to be a more direct method.

:laughing: If there’s one thing I’ve learnt, fiddling about with home assistant, it’s usually a fairly simple mistake buggering the whole thing up!

Glad your perseverance has paid off. I did try writing the file to the boot partition but I couldn’t get that working either. I was able to use that method for hassbian but not hassio, although there’s a fair chance it was just a typo.

Thanks for posting this, it’s good to know it is possible to use the Pi Zero. I was thinking this could be an interesting platform for a smart vehicle, like a campervan (not that I have one… yet!).

I think due to its smaller power consumption, a pi Zero would be ideal for such a project. Don’t let the fact that you haven’t got the van yet stop you! Preparation is king!
I was on a roll until today, got hassio installed, WiFi working, samba connection to windows, then… wouldn’t boot up anymore! I hadn’t messed with anything, just switched it off for the night so I am going to start from scratch with a new SD card.
@pizero seems to have had success with his Pi Zero so I am leaning towards the storage as opposed to the OS or Pi.
Updates as they occur…

1 Like

Hi again,
As suspected, crappy SD card! Ali express is good for most things but not those! Got a couple of 32gb cards from Amazon and everything so far works like a charm.

Yes the Pi Zero is obviously slower but a bit of patience pays off here. So far got samba working and configurator up and running (mqtt is installed too but not yet set up).

I’ve registered for duckdns but seem to be having a bit of trouble there (I’ll start a new thread for that 1)

As for tips, the config USB definitely works, just got to follow the instructions to the letter.

Wish you all success with your devices, perseverance and this forum are the answers!


1 Like