Help Required to Get HA Running on RPI 4b

Hi, I am a complete novice with Home Assistant and only slightly better with Linux, so I am really looking for some guidance.
I am trying to get up and running with HA on a dedicated RPI4B. So far, I haven’t managed to get access to HA after installing it. This is my steps so far:
Installed HA (64 bit) on a new 64G card using the procedure here Raspberry Pi - Home Assistant
tried accessing HA via both homeassistant.local:8123 and homeassistant: 8123 with no response
Tried the same procedure with the 32 bit version and no success again
Re-flashed the SD card with the 64 bit version and left it running overnight with the same result
Replaced the power supply with a 1.8A laptop power supply - same result
Also replaced ethernet cable and powered down the RPI several times
looking at the SD card I can see that files have been loaded and the card is titled hassos-boot

one positive note is that I can ping both homeassistant.local and homeassistant, so I assume HA is actually running

Where do I go from here as I really want to get Home Assistant up and running?

5V 1.8A still is a bit low. Is that figure correct? Even an iPad charger will supply up to 2.4A.

That said, if you can ping it I expect you should be able to connect.

You could:

  • plug a display into the Pi and see what the console output shows
  • try a different browser

Yeah that is low the minimum recommended for the 4b is 3 amps at 5 volts.

Did you try accessing it like this?


Can you see it’s ip address (in your router etc?)

Plug it into a monitor and keyboard. What does it say on the screen? (You may have to reboot for the screen to be recognised by the pi)

what leds are flashing on your raspberry. Any issues with power are always visible on red led. Also green one needs to be flashing to indicate something is happening on the sdcard.
if either of these are not in line, there is not need to search further and just get the rightpower supply.

This just worked for me. I use a PoE hat to power it. Be sure to log into your router and give it a reserved IP address before trying to log into it.

Some success. I changed the power supply to a 3A version, although with the original 1.8A power supply the led was on and not flashing. Plugging a monitor in (after getting a micro HDMI adaptor, hence the delayed response), and I can see the various functions loading and eventually I get the CLI loaded and the HA prompt, so it appears that all is OK and I may have a problem with the ethernet port. BTW, green led flashes, showing that the SD card is being accessed and the red led lights but then goes off and stays off.
I would now like to get wifi working, so how do enter the SSID and password so I can get an IP address and access the GUI?
Thanks for all the help and suggestions so far - keep them coming.

Suggestion: don’t run HA on wifi!

On the CLI load, you are told what IP address the machine has. What does it say? See my post here

Ater the CLI loads, there is no IP address for both eth0 or wlan0, so somethings not right. Where do I go from here?

Plug your machine into a wired network, with a dhcp server. Reboot.

Do the ethernet leds light up? and what pattern if yes.

@nickrout making some progress. Had an old broadband router, so removed the password and connected it to the rpi and got a valid IP address. I was then able to access Home Assistant via the homeassistant.local:8123 and start the installation. I then struck the well-known everlasting “Preparing Home Assistant (this can take up to 20 minutes)” issue. Looking at the supervisor log, it looks like I need an internet connection to do some preparation and/or updates, but my temporary router has no internet connection. My current broadband router is a Telstra Gen 3 and it looks like I can’t temporarily cancel the password to get internet access, so I think I need some way of putting a password into Home Assistant to access the internet-connected router. Alternatively, can I use wifi to gain access - tried wpa_supplicant without success, so looking for an answer to getting internet access?

@checking12 the question you asked about ethernet lights is not valid now, but the answer anyway is flashing green led and yellow are both lit.

Getting closer …


Couple of options.

  1. If your old router has an ethernet WAN port, set the WAN port to use DHCP and connect it to your Telstra router (you will need to use a seperate IP address range where HA is now). If it is the same address range, disable NAT (firewall) on your old router so it just passes traffic through. The Telstra router should act as the DHCP server.

  2. If your old router is allocating ip addresses in the same range as your telstra router and the allocated IP is not in use, you might be able to just connect your Pi to the Telstra router.

  3. The best long term solution, is to buy something like this. That is heavilly discounted.

Place it behind your crappy Telstra router and turn off NAT and wifi on the Telstra Router and let the Netgear be you main router. I’ve attached a diagram. This will save you a lot of grief into the future…

Here is what my network looks like. Best thing I did 10 years ago was to wire the whole house for network…

I put my router up high for the wifi but I follow the same best practice design

Get your network set up properly now for the future.

The installer downloads home assistant. Sort your network out.

1 Like

Success! turned out to be a faulty inter-floor cable, so once that was fixed Home Assistant downloaded and installed, so now running successfully.

@rodw I moved into a “new” house that had Cat5 cable installed when it was built (10 years ago), and there is a data appearance in quite a few rooms, so that aligns with your suggestion, and that is why I had a problem connecting to the web due to a wiring issue. In regards to the Telstra Gen 3 modem/router, it appears that I can’t turn of NAT, but I do agree with your suggestion for a discrete wifi network, so will look at that down the track.

Thanks to all the suggestions on resolving my issue by various people.

1 Like