Help ridding myself of unnamed device!

First off, very new to HA and Trying to get the basics set up and I have had an unknown device from day one. I really can’t figure out how to get rid of it!ha1

I think I have included the parts of my configuration.yaml that needs to be seen…
light 1:

  • platform: lifx

light 2:

  • platform: osramlightify

light 3:

  • platform: yeelight
    name: Stair top



view: yes

icon: mdi:home


- group.light_panel

name: Tree
- light.tree_top
- light.tree_mid
name: Porch
- light.door
- light.grill
name: Stairs
- light.stair_top
name: Bathroom
- switch.bathroom_heater
name: Light groups

As I said, brand new to the platform and the system. I have been using IFTTT and the manufacturer apps for automation along with Alexa. I would like to get to the point that I do not need the manufacturer apps, somewhere down the road.

The parts that are commented out are my efforts at trying to shape my homepage. I will address that later, once this device is gone.
I am trying to make the landing page show all of my light groups only, had that working but I would also like a block for some of the light sets with only an on or off for the entire set. Then I would like the individual controls in tabs, so I can address each one.

Thanks Matt

Sorry, could not figure out how to post the configuration file cleanly…

Solved! It was a ghost on my Osram hub.

How did you solve it? I have an “unnamed device” and an “unnamed device 2”, with one of those actually being one of my Osram Lightify bulbs. Unfortunately when I reboot it tends to switch to the other unnamed device.

I unplugged the Lightify gateway for 15 mins to make it forget its mapping table, but without any effect.

I had installed 2 bulbs, one fail right away. That bulb was my ghost. I went into the Android app and removed the bulb from the Lightify system and restarted the hub. Then, I restarted HA and the device was gone!

Good for you, not in my case though… :frowning: I have all my working bulbs in the Lightify Android app, but only 2 of them in home-assistant. The third, missing bulb seems to be “unnamed device” AND “unnamed device 2”, just not at the same time but alternating.

But the problem seems to be with OSRAM Lightify, since even Alexa sometimes can light that specific bulb, but sometimes it can’t find it.

Thanks anyway!

I also had the issue of Alexa thinking the ghost was there. Are you current with firmware on bulbs and hub? This issue really sounds the same as mine.

Yes, firmware on all Osram devices is up to date, problems prior and after the updates.

Yesterday I completely reset the gateway, and later removed all devices three times. It seemed to make a difference wether homeassistant is running at that time or not. When homeassistant was running while I was adding my devices to the Osram gateway, I ended up with THREE! unnamed devices, both B40TW and the plug. When I stopped homeassistant für the process of re-adding all devices, I only had two unnamed ones, one B40TW and the plug. Strangely before all that testing the plug was properly registered with its name, and now it isn’t. I might need to reset the devices themselves.

It is all a bit erratic.

Solved with the help of OSRAM Lightify support - in the Lightify app under “devices” I chose the device that I know to be “unnamed device” in HA, tapped its name at the very top which places a cursor in the devicename so I can rename it. I did that for all devices (simply removing the space between the device type and the number, to keep it consistant). After restarting HA all “unnamed devices” were gone and the proper named ones in their places. Voilá!

Good news… This may help some folks since it does seem to happen and is a pain when it does. Thanks for sticking with it, better answer!