Help RP4 HA will not survive a reboot


I am new to HA, well I tried sometime back on a RP2 and came back to it now with a RP4. I have installed the latest HA image using balena etcher and it boots up fine.

The problem I have been having is that after I have gotten a few modules installed such as Node red, mosquitto mqtt broker, isy integration and node red hubitat flows. The system will not survive a reboot.

When rebooted the command line does come up but when logging in as root I get the error

Home Assistant CLI is not running! Jump into emergency console …

systemctl status gives me a degraded error with no explanation.

I have searched google and the forums and have seen similar problems, mainly related to the time service. In my case though there are no errors in the bootup sequence or when I run the timeservice from the command line. It seems to work with no errors.

This has happened now at least 4 times, I have tried multiple sd cards mainly to be thorough. I know almost nothing about linux so this has become very frustrating.

My main reason for HA is to help integrate the seperate hubs ISY and Hubitat elevation and tie in my ADT Pulse alarm.

Any help would be appreciated.