Help setting up nginx and duckdns

Trying to get away from the usual duck dns lets encrypt ssl setup and go for a set up with nginx and duckdns. Can anyone help me get this set up? I am trying to do so to get a konnect board up and running better. This setup was recommend by the konnected developer but I cant quite get it working. I have the nginx and duckdns add ons installed and configured. I can access hassio via on my locl network and can confirm this is a much better setup for konnected but I can’t seem to access hassio from outside my local network now. Can anyone help? It may be a port forwarding issue I have 80 443 and 8123 all forwarded and have tried all kinds of combinations there of but nothing seems to work.

This solved my duckdns issue of not able to access from outside … Sorry , I dont know if this helps with nginx

Step 1. Uninstall DuckDNS from HassIO.
Step 2. Goto your routers port forwarding settings. Forward port 80 external to 80 internal at your pi's IP. Do the same with 443 external to 443 internal at your pi's IP.
Step 3. Re-Install DuckDNS with your key, accept terms and domain and start the add-on. Keep refreshing the logs down the page to ensure that DuckDNS has created the certs. This may take 10-15 mins it did for me.
Step 4. Once DuckDNS has created the certificates add these lines to your configuration.yaml
http: base_url: ssl_certificate: /ssl/fullchain.pem ssl_key: /ssl/privkey.pem api_password: Secure password
Step 5. Go into your routers port forwarding settings delete the port forward 80 external to 80 internal and change 443 external to 8123 internal at your pi's IP.
Step 6. Restart Home Assistant and navigate to or whatever your domain is. Enter your password set in api_password: and log into Home Assistant.

Were you ever able to figure out duckdns and nginx for Konnected device set up?