Help to reinstall HA please

Something went wrong and I need to reinstall HA. I have install HA following this guide

Since ubuntu is installed, can I just follow the following to reinstall HA or I must (how?) uninstall it first?

Copy each line of the below commands and paste them into a terminal/Putty window, and execute them one at a time.

add-apt-repository universe
sudo -i
apt-get update
apt-get install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat
systemctl disable ModemManager
systemctl stop ModemManager
curl -fsSL | sh
Now the machine has everything it needs to run Home Assistant. The following command will download, install and get Home
Assistant - Supervised up and running for you;
curl -sL "" | bash -s

Are you sure?

This is rarely the answer.

no i am not.
but i have problem with an integration that I can not resolve and I think the only way is to reinstall it.
Right now I have 12 switches (lights) that are unavailable :frowning:

I tried several times to delete it through config entries,device/entities registry, but HA wouldn’t start.
I have copies of them and now it is functional again but not my lights. I also tried to restore from previous version.

Now it won’t let me even do a restart. I am getting this

Log Details (ERROR)
Logger: homeassistant.components.hassio
Source: components/hassio/
Integration: (documentation, issues)
First occurred: 5:19:10 PM (4 occurrences)
Last logged: 6:50:49 PM

Component error: meross_cloud - Integration 'meross_cloud' not found.

What else can I do?

You need to look in the .storage files and remove any reference to it, taking extreme care to maintain the json file structure. Making a backup copy of this folder and placing it somewhere other than in the config folder would be prudent.

I have tried this but unfortunately I can 't. Every time I am deleting something wrong and HA won’t start.
I replace the the original folders etc, but I am stuck. I am doing this the past 8 hours. That’s why I am asking for a reinstall. But as I see it is difficult too (for not experience user)

The easiest thing to do would be to restore from a snapshot taken before the trouble began. Do you have one?

1 Like

I have done this. but the problem remains the same.

Do you know what is the difference between restore and wipe and restore?