Help troubleshooting notifications on iOS

I’m trying to troubleshoot why I’m not getting notifications on the Hass app on iOS. One of the first things I see in the troubleshooting section here:

says that I should see a notify.mobile_app service in the Developers → Services area, however, I do not. I set up the app on iOS, I see that my iphone shows up in the integrations area with one device and 18 entities. I can see that there is a push ID when I go to Settings → Notifications → Home Assistant → Home Assistant Notification Settings → Push ID. In addition, I saw an article where someone had solved the issue by resetting the push ID, so I tried that, but it didn’t change anything.

I can’t move on to the next step of troubleshooting this issue, without this being resolved but the FAQ article doesn’t really explain other steps to try. I see some older posts from 2020 and 2019, but they are saying things which don’t seem to match up with current versions of Hass, so again I’m a bit stuck. I appreciate any suggestions.


Try going into the app and pull down on the screen to force a cache refresh. You can also do this under debugging in the App - refresh front end cache.

I did the pull-down method, but that didn’t seem to change anything. How do you access this debugging menu? I don’t see that anywhere which I can find.

The App settings are in the HA menu-


Got it, thank you. Still no luck though unfortunately.

In hunting around in that menu though, I noticed that under HA menu - Companion App - My Server - Local Push, the value is “disabled” which seems wrong but I don’t see any place to change that. Is that helpful to know?

I also think you are checking old docs as there is no notify.notify_mobile_app setting anymore

If you can see your phone in devices/mobile app then notifications should work if they are formatted correctly.

1 Like

Do you have notifications enabled for the App in iOS ?

Ok, that helps me quite a bit. Then I think my next step is troubleshooting the message itself. I just took an example I found in the HA docs and put it in place with some adjustments for my own environment:

  - alias: "Send Notification with a link"
      platform: state
      entity_id: switch.living_room_corner_light
      to: 'on'
      - service: notify.mobile_app_iPhone11
          title: "Corner light has turned on"
          message: "Light just turned on"
            # iOS URL
            url: "/lovelace/home"

This should send a notification when the corner light turns on, but it doesn’t seem to operate. I’ve added this into the configuration.yaml file.

btw, if I didn’t mention it, I am brand new to HA and still working to pick things up, so my apologies for any noob mistakes I’m making.

You should still see the service

Did you allow iOS to send the notification?

1 Like

I do, I have all the same items turned on that you’re showing.

Does that automation show up under Configuration/Automations? If it does then pressing Run Actions should send a notification.

1 Like

Well I’m not quite sure where things fell into place, but I checked under Configurations → Automations, and manually ran the notification from there and it worked!

I also see it showing up under Developer Tools → Services when I start type “notify” in the service list. So, I think I’m good.

My thanks to @BertrumUK and @deluxestyle for your responses! Much appreciated!

Great news. Glad we could help / provide some things to check.

1 Like

If all on HA side is functioning, but you still don’t receive notifications on you mobile, it could be HA lost the Push_ID of the phone. In order to refresh it, you need to generate a new Push_ID.
This can be done on your phone, under:

configuration\ companion app\ notifications \ Reset (at the bottom)

1 Like

Not addressing your issue with Home Assistant native notifications. However, if you want a ‘B plan’ or something to compare and contrast with, I have been very happy with the Pushover integration for 2 years now:

Thank you, this was my problem, I just had to reset the push id, and it fixed the problem.