Help! Why after install HA on Raspberry PI OS Buster, HA is not same configuration than when i have installed it in version Hassio?

I just discovered HA and in three days, I tried HA in Hassio AllInOne version.
All work well, about Z-wave, Zigbee, Hue, Hank, Camera ONVIF, Camera usb with Eyemotion, etc …
but all Add-ons not work well. For example, Samba. Do not want to start, and when I change the smallest detail in the configuration, when saving it, I am always entitled to the same error.
In this example, i use the defaults sets and mod only the password of NULL to 0000. But when i save … (see the Gyazo for the error received)
In addition, many Add-ons that are supposed to start with a restart do not. As with Samba, SSH does not start.
So I have no way to add Hacs or any other Repositories I need.

So I wanted to try HA by installing it on Raspberry PI OS Buster.
And there, Big surprise !! I don’t have a Supervisor.
So no Add-ons possible.
And ONVIF did not want to settle, despite a first attempt, and the following attempts, always lead to the return to the beginning of the list of choices after having clicked on ONVIF.

I know that in this message, I am in demand on many points at the level of installation and configuration.
In addition, on two of the possible ways of installing HA.
But I wish I could get there in both ways and learn to master them.
Because my objective is to have a version reserved only for HA use (Hassio) and another version, more open to adding other functionalities depending on Raspberry PI OS, while making HA work on it at the same time.

I hope I have been clear enough, and my apologies for my English.
Thanks for your help and don’t hesitate to ask me for other Gyazos just in case.
Both version installed are done on two Raspberry PI 3 B+

1 Like

Your samba password needs to be quoted.

For Home assistant supervised (it is not called hassio anymore), see

TY Francis for the info about the ‘quotes’ for password.
so I installed a new fresh installation of raspberry OS PI Buster on an NMVE disk, booted on USB 3 of RPI 4 B.
With the quotes around the password, now when I save, I have no more errors and the Add-on start.
On my network, I discovered Homeassistant well.
I access it, but only the ROOT and HOME PI folders are accessible. The HOME ASSISTANT folder remains inaccessible. However, it is the latter that I need to install HACS.
What should I do to access it?
Thank you in advance.