Help with Alexa/API

I’m trying to set up custom commands via Alexa, using the instructions here:

However, all I get from Alexa is:
“There was a problem with the requested skill’s response”

This is whether I used a valid intent or no. I get no JSON Output in the debugger.

I am wondering, should I be able to hit /api/alexa via browser or CURL? When I do, I get “404: Not Found”

I tried doing the api setup (which is just adding the api tag to configuration), and if i get /api/ I get “401 Unauthorized” which at least sounds like that is listening.

Any ideas where I have gone wrong? I’m running via docker, using latest version (94.3).

Other points worth noting:

Yes, I do have port 443 open, and can hit hass from outside from both 8123 and 443 (which I have forwarding to 8123).

I also have had the Cloud configuration setup, per the below link. That DOES work, and I can control switches and what not from Alexa. However, I tried specifying both by DDNS link as well as the Nabu Casa URL as the endpoint (and via cURL), with the same results.

Never mind, finally got it. I assumed the alexa: component under the cloud was sufficient, but I had to add an additional alexa: tag NOT under cloud. Works now.