Help with APA102

I want to connect an APA102 led strip to an ESP32 devkit v1.
I’m using the following config for the led strip:

  - platform: fastled_spi
    chipset: APA102
    data_pin: GPIO25
    clock_pin: GPIO26
    num_leds: 50
    rgb_order: BRG
    name: "Bed light"  

light.bed_light shows up in HA and I can turn the entity on/off. However the led strip doesn’t show any activity.
Here’s the log output when switching the entity:

[19:32:46][D][light:035]: 'Bed light' Setting:
[19:32:46][D][light:046]:   State: ON
[19:32:46][D][light:084]:   Transition length: 1.0s
[19:32:48][D][light:035]: 'Bed light' Setting:
[19:32:48][D][light:046]:   State: OFF
[19:32:48][D][light:084]:   Transition length: 1.0s

nothing weird happening there, right?

I used an esp8266 (wemos d1 mini) before and that worked so the wiring of the led strip should be okay.

my setup:
5V 6A power supply, connected to 5V and GND on led strip
power supply connected to VIN and GND on ESP32
DI - D25
CI - D26

I know the ESP32 is working because I also have 4 bed occupancy sensors connected to it and they provide accurate data to HA. I can’t use the esp8266 because that apparently doens’t work with the bed sensors that I’m using (the capacitive ones with the paper/foil)

What am I missing here?

My immediate thought was “common ground” - are you sure your wiring achieved this?

I have changed my setup, same result. I am now using a hx711 + load cells for bed occupancy instead of the paper/tin foil method. And I switched the esp32 for esp8266 (wemos d1 mini)

HX711 (load cell converter) GND → V- (5v adaptor)
Wemos D1 mini GND → V- (5v adaptor)
APA 102 GND → V- (5v adaptor)

In this setup again the load cells are working, the led strip isn’t and vice versa :frowning: