Help with automation that stopped firing

I’m new to HA, running on blue. I just moved from deCONZ to zigbee2mqtt since the dimmer remote I want to use would not pair with deCONZ. It’s an AONE Aurora AU-A1ZBR2GW wireles dual rotary dimmer.

I was setting up automations for it and started with setting the left dimmer to a light group, and the right one to a single bulb. Worked fine. I moved on to set the on/off toggles, and while they too worked as expected, the dimmer automations stopped working right then.

I changed nothing in between, they worked consistently until I moved on the the other automations, and now they just WILL NOT fire. I’ve deleted them all and back to trying to get just one to work. I also tried disabling all the other automations. I can run the actions manually.

Here is the automation:

alias: aurora_dimmer_ljosakrona_up
description: ''
  - platform: device
    domain: mqtt
    device_id: 2d6cf9148cd4263ce2dcaf9e1a1b78b3
    type: action
    subtype: color_temperature_step_up_left
    discovery_id: 0x000d6ffffec1bdcc action_color_temperature_step_up_left
condition: []
  - service: light.turn_on
      entity_id: light.ljosakrona
      transition: 1
      brightness_step_pct: 5
mode: single

A screen capture that shows that HA actually sees the events firing:
Screen Recording 2022-01-10 at 22.27.19

Here is my full list of automations:

Not sure if this means anything, but the automation has a different name in dev tools for some reason, the last one…

I solved it. I’m not 100% sure what I’m doing after going in circles trying to add an external converter to zigbee2mqtt two new actions were exposed. I wish I understood why, maybe I will one day…