Help with customising iTag BLE tags

Hello everyone

I’ve bought a 5-pack of these iTag BLE tags (the kind that are shaped like a teardrop -

They’re working great so far with my ESP32.

Couple of things though.

When I reboot my ESP32, the BLE trackers disconnect - this makes them freak out and start beeping like crazy. Is there some way I can disable this?

I did some googling and apparently this app can do it: - however it is an android only app, and I do not have one of of these phones.

Secondly, is there some way to disable the beeping? I am really using these things as buttons to trigger stuff in HA - not for finding lost items so the beeping is just annoying.

Lastly - is there some way to crank up the transmit power? It only has a few feet of range, I guess it works great for the purpose it’s designed for (which is alerting you when you leave stuff behind) but I am using them as switches, and sometimes just moving it a few feet makes it lose connection and my automation don’t work.

When it is working, it is great though! :wink:

Can just open up the device and use a snips :scissors: to cut the traces to the buzzer - it will probably just pop off easily. Then you have always :tm: silent button :raised_hands:

Probably not.


Hi ID9000, I have your exact same iTAG, as you said “They’re working great so far with my ESP32.”, can you please be so kind to explain how you configured it in HA?

I have 2 ESP32 in every room, one wirh ESPHome BT Proxy and the other with ESPresense, ESPresense is working just great with iBeacons of my mobile phones but I cannot manage to configure this iTAG correctly. I think this has something to do with the sensor configuration in HA.

This is the sensor config of my phone:

  # Configurazione sensore per ESPresense
  - platform: mqtt_room
    name: "Simone ESPresense"
    device_id: "iBeacon:c6a47b33-56f2-47c2-9884-6835e05caec2_1001_1000"
    state_topic: "espresense/rooms"
    timeout: 5
    away_timeout: 60

And this is the one of my iTAG, it is surely wrong but I don’t know how to set it up:

  # Configurazione sensore per ESPresense
  - platform: mqtt_room
    name: "iTAG ESPresense"
    device_id: "iTAG:FF:FF:10:44:06:BF"
    state_topic: "espresense/rooms"
    timeout: 5
    away_timeout: 60

Looking at ESPresence log, iTAG is detected but I don’t know how to use those info to setup the sensor:

[10:09:07][VV][esp32_ble_tracker:575]: Parse Result:
[10:09:07][VV][esp32_ble_tracker:592]:   Address: FF:FF:10:44:06:BF (PUBLIC)
[10:09:07][VV][esp32_ble_tracker:594]:   RSSI: -86
[10:09:07][VV][esp32_ble_tracker:595]:   Name: 'iTAG            '
[10:09:07][VV][esp32_ble_tracker:603]:   Ad Flag: 6
[10:09:07][VV][esp32_ble_tracker:606]:   Service UUID: 0xFFE0
[10:09:07][VV][esp32_ble_tracker:609]:   Manufacturer data: FF.FF.10.44.06.BF. (11)
[10:09:07][VV][api.service:334]: send_bluetooth_le_advertisement_response: BluetoothLEAdvertisementResponse {
  address: 281470954636991
  name: 'iTAG            '
  rssi: -86
  service_uuids: '0xFFE0'
  manufacturer_data: BluetoothServiceData {
  uuid: '0x0105'
  data: '\xff\xffD\xbff

Regarding your question on the disconnect beep, I have an option to configure the disconnection beep in the iTAG app (Named Kindelf) but still it beeps the same when disconnected :frowning:

Nevermind, just after writing the post above, I solved it.

For the records: I installed MQTT Explorer on my PC and it is beautiful and well organized, this allowed me to see all BT devices with the exact name to be used in the sensor configuration and now it works perfectly! :slight_smile:

Hello everyone, it seems that with esphome we can have the following sensors:
Is it possible to trigger the tag to ring ?
Thanks in advance?