Help with Ikea Tradfri Shortcut Button (1 working, 1 not)

Hello,

I am having difficulty with one of the two Ikea Tradfri Shortcut Buttons that just arrived. I was able to set one up no problem, but the other one is proving quite difficult.

I am using this Sonoff Zigbee 3.0 Dongle Plus. Here is the specific Tradfri device. I am using the Zigbee Home Automation (ZHA) integration.

Like I said, I was able to set up one button no problem. It was discovered quickly, the information detected about it seems reasonable, I could see zha_events in the developer tools, and I can successfully use it in automations (using this blueprint).

The other button, on the other hand, has strange information (see below), no events appear when I monitor zha_event in developer tools, and when I use it in an automation, nothing is fired.

Working diagnostics (labels have sensible names, battery level is detected).
image

Broken diagnostics (labels have strange names, battery level not detected).
image

I have tried resetting and re-pairing the device many times. I have also replaced the stock battery from Ikea with a brand new battery as recommended here.

Did I get a lemon? Is there anything else I can try. How should I go about debugging this? I know my configuration is good because one of the two buttons that should be identical is working.

Thanks

1 Like

same here…

1 Like

same here…

1 Like

I had the same problem. I added a third, and there was no issue, so I removed the problematic button from HA, replaced the battery, held the pairing button on the button for 10sec (I have zero idea whether this resets it or not, but it’s consistent with other IKEA rest procedures), restarted HA, then re-added and it added properly.

I have the same issue, has anyone resolved this?

I did what @deadsquid said but it returns in the same state as OP

My logs are full of zigbee errors, which I can provide if useful to someone

Same issue here :frowning:

I even got a shortcut bututon to work. How? No idea - I’ve only read various things that you should initiate an OTA update and then the detection should work better with HA.

Be sure to upgrade Zigbee Coordinator firmware, add USB extension cable + use a USB 2.0 port. See:

https://github.com/home-assistant/home-assistant.io/pull/18864https://github.com/home-assistant/home-assistant.io/commit/970295a277e8f01d3ee39eeeaacf453625b988d3

also read and follow:

https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties

If using Home Assistant 2022.4.x then there are bugs with ZHA quirks in that are being worked on, see

https://community.home-assistant.io/t/zha-event-trigger-for-automations-stopped-working-in-2022-4-0-solved/409228/

So downgrade to Home Assistant 2022.3.x or wait for a fix.

How do you send an OTA update to the button?

2 Likes

I have exactly the same problem with Ikea Symfonik sound controllers. One works great, the other added later does not have any events. I’ve reported this here:

The OTA udpate documentation is here Zigbee Home Automation - Home Assistant … I have set the configuration.yaml to auto update Ikea but the instructions to manually update are a little too complex for me to understand where and how :smile:

I’m having this same issue with some shortcut buttons (3 not working and 2 working) and two STURBAR remotes. ZHA says it finds them but nothing works and the battery just says ?


If you want to perform manual update of only some specific IKEA device(s) instead of automatic update all all IKEA devices then you first need to find copy if the OTA firmware image version for the specific device that you want to update, see ex:

https://github.com/zigpy/zigpy/discussions/660

More links here:

https://github.com/zigpy/zigpy/blob/8fefb7c8cf327858c35002a66c3e3cac31fdafc4/zigpy/ota/OTA_URLs.md

Then to update manually copy OTA images files to the otau_directory after you created as such folder:

https://www.home-assistant.io/integrations/zha#ota-firmware-updates

zha:
  zigpy_config:
    ota:
      otau_directory: /path/to/your/ota/folder  # Utilize .ota files to update everything else

FYI, looks like someone is working on updating the ZHA quirk for IKEA’s SYMFONISK remote here:

https://github.com/zigpy/zha-device-handlers/pull/1552

I’ve got a similar issue, but in my case the button was working then stopped. I have performed a reset and re-add, but no luck. I bought a new button yesterday thinking I just had a bad button, but the new one is exhibiting this behavior too.

I hade the exact same problem as the rest of you and then it just started working after me tinkering with the button by re-paring it? :man_shrugging:

It does seem that the Ikea buttons, when used with Home Assistant, are somewhat flaky and I have absolutely no idea where the issue lies.

I have a reasonable number (18) of the Ikea shortcut buttons and if I pair one or two of them up then they seem to work (albeit the battery level reporting seems very hit and miss as to whether you get anything shown or not) - I created a test automation just to toggle a socket on and off when a shortcut button is pressed and added buttons to HA (using a Sonoff Zigbee 3.0 dongle but I have several others and they all seem to do the same) adding them to the test automation as I go and I end up with earlier buttons no longer triggering the automation.

I have a single “on/off” button and that seems fine but I haven’t got multiple ones of those to try.

I have just dug out my Ikea Tradfri gateway (which I’ve had for several years but never used) and paired up all the switches to that to see if they’ll update their firmware … they all look to be on 2.3.15 firmware (even though some were bought a few years ago and some were bought two months ago) and the current firmware appears to be 2.3.80 … they’ve been set up on the gateway for a week now and about half have updated to 2.3.80 so far but oddly both the ones with 2.3.15 and the ones with 2.3.80 show as “Up to date” even though so far 8 of the ones that were “Up to date” on 2.3.15 have updated to 2.3.80 … and of course there is no way to force an update, you just seem to have to wait for the random interaction of cosmic rays to make that work.

So, unfortunately, it seems that the Ikea Tradfri stuff is flaky as hell at the moment … and using the Tradfri Integration with the proper Gateway seems to only give me the battery levels for all the devices, nothing else, no way to actually use any of the buttons, switches or sockets but perhaps that’s because the Gateway firmware is out of date? Who knows? The software reports that it’s “Up to date” but it also shows the remaining 8 shortcut buttons that have 2.3.15 on them as “Up to date” however another 4 of the 2.3.15 shortcut buttons are also showing as “Updating” as did the ones that are now on 2.3.80 so who can be sure?

Today I found out that my two shortys start to work after i pressed the pairing button for a long time. Everything was already set up. They were paired and there were test automations. Pressing thepairing button first the button started to light up. After several seconds the button flashed a few times and afterwards it just worked. I didn’t even pair them again. All the automations I set up with the blueprint worked. I needed 6 months for this solution but now I’m really happy it functions now as intended.