Help with MOES Smart IR Controller (Tuya) - Serial Flash ok - No normal boot

Hi, I’m trying to flash Tasmota/ESPHome to a MOES Smart IR Controller.
It has a TYWE3S chip, so I think it should be possible.

From the outside is the same as the one in the guide , but the board is a bit different.

I tried to use tuya-convert but it doesn’t work. It seams that it has a newer, patched firmware.
It doesn’t have pin holes, so I had to solder wires directly to the chip TX/RX/GIPO0.

I’m able to put it into flashing mode, and connect to it with esptool.py.
I can get flash id, erase flash, and I’m able to write_flash the Tasmota firmware and a bare ESPHome firmware.

Output when flashing:

esptool.py v3.0
Serial port /dev/serial0
Connecting....
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 8c:aa:b5:fd:8e:3d
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Compressed 427120 bytes to 292534...
Wrote 427120 bytes (292534 compressed) at 0x00000000 in 26.4 seconds (effective 129.3 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin...

But when I boot in normal mode nothing happens, no AP Wifi is created to connect to.

I flash from a Raspberry Pi, and I tried to leave the serial connected after flashing, to see any bootlog.
Set the baudrate to the non-standard 74880 and was able to get this output:

With GPIO0 Floating:

ets Jan  8 2013,rst cause:2, boot mode:(1,0)

With GPIO0 to GND

ets Jan  8 2013,rst cause:2, boot mode:(1,7)

It seems that it is still in flashing boot mode, because of the (1,x) according to this resource
But no reference on what the 0 or the 7 mean.

I made the mistake of not backing up the stock firmware, so now it seems to be bricked :frowning:

Any ideas are welcomed.

Adding some photos of the board and the connections:



GPIO0 was directly not soldered to anything in the board, so it doesn’t have any pullup resistors.
When I connect GPIO0 to VCC (directly, whit out pullup resistor) to go to normal booting mode, nothing happens.
I don’t get any output in the serial terminal.

Hi, I found the culprit: my lousy soldering.
The cable in GPIO0 was touching the metal shielding of the chip and so I couldn’t be set to high. That is why it was always in boot mode.
Removed the cable and now it is booting.

Now I’ll continue with the ESPHome configuration of the devise.