Help with RFXtrx

I got myself a RFXtrx433E that I´ve configured in HA.
Most of my switches are added as expected but I have some issues with some switches/sensors that does not work in HASS.
Both the switch and the sensor show up correctly in RFXmngr.

The switch is a Rising Sun (non self learning) added as Lightning4. It show up with an ID but I cannot control it, no response on on/off. It also seems it creates duplicate entries in HASS since I have two ID:s

The Sensor is a Maverick BBQ 732 (Hideki), It doesn’t show up at all.

Does anyone know why these two does not work in HASS?

Also, when the RFXtrx433E is connected to my rPi, shouldn´t I be able to connect to it using RFXmngr and the TCP/IP option?



fire_event: True

I tried this, unfortunately no go :cry:

What do you mean with that?
Check the fired event in the log when the switch is triggered. That should work.

Sorry for being unclear.

I toggled my switch using Tellstick, this makes a rfxcom switch appear in UI since I have auto_add enabled.
I took that switch ID and added in conf with the option fire_event.

  - platform: rfxtrx
    automatic_add: True
    signal_repetitions: 2
        name: Kitchen Test
        fire_event: True
        name: Kitchen Test2
        fire_event: True

After restart of HASS I still can´t turn on/off the lamp using these switches.
A new rfxcom switch is also added if I toggle the switch using Tellstick again.

I don´t have this issue with self learning Nexas.

1 Like

Hmm, any errors in the log during startup?

What happen if try to toggle the switch from Tellstick?
Then the rfxtrx switch should also toggle. Check the log for something like
[homeassistant.components.rfxtrx] Rfxtrx fired event: (event_type: button_pressed, entity_id: switch. ......

No errors during startup.
If I toggle with Tellstick the rfxtrx switch doesn’t change.

With the Nexa switches I get behavior you describe: The switch toggle when I change using Tellstick.

I don´t know if this is a problem with the Lightning4 protocol or that the switches are not self-learning.

@turbokongen Do you have any suggestions here?

Not any particular, but the risingsun is a protocol on 433mhz, that is supported by rfxtrx433.
Lightning4 is also the protocol for the cheap PT2262 based devices, which is not fully supported I guess.
The best thing you can do is to have debug enabled, and turn the switch on and of several times and compare the two packets recieved. Atleast it should be just two different.
As for the sensor, I don’t think that is supported in the rfxtrx lib. It uses a different packettype called BBQ:
First post here shows that: Empfang BBQ-Thermometer Maverick ET 732

Decoding that post with available info:
0A: Packetlenght
4E: Packettype
01: Subtype
5C:Sequence rbr
00: Id1
00: Id2
00: Id3
1B: Temp sensor 1
00: ?
1A: Temp sensor 2
9: Battery


Great input @turbokongen!

I can see that the Rising Sun switch is a rsl366R.
There is some additional info here regarding the pulses, maybe that can help?

Found some similar issue but different brand, A tip there:

OK, so it seems that these switches are a little problematic.
I guess I could use my old Tellstick for these but I would prefer not to run two 433 devices.

I don´t know how to implement this tip in HASS

I recently bought some RSL366R and also had the problem, that I couldn’t add them in the domoticz add switch dropdown.
now I simply picked “RisingSun” in the dropdown and set it to “A,1” (my testing RSL is set to “I,1”) and the RSL works! :slight_smile:
I’m using latest rfx433 Type1 fw (86) and the RSL is detected as Lighting1.

Is is possible to add the BBQ codes into the rfxtrx lib?