Help with setting up Z Wave JS UI

I’m running into an issue with the last step of setting up Z Wave JS UI. I have the Z-Wave JS successfully added to the sidebar, and I can see my Z Wave devices connected inside of that.

The next step was to connect it to HA so that I could access the ZWave entities.

When I try and add the integration on the Devices and Services screen.

I select “Setup another instance of Z-Wave”
I am sure to unselect “use the Z-Wave JS Supervisor Addon”
When it asks for the URL I have tried “ws://localhost:3000” and “ws://a0d7b954-zwavejs2mqtt:3000”, but both will error and say 'Failed to Connect"

When I first tried to setup the new ZWave JS, I did accidently install the non UI version. I have now uninstalled that.

Apologies for the rudimentary question. I have not touched the HA in 3 years, and was forced to update it when cloud control stopped allowing me to access it due to it being so far out of date.

Make sure the WS Server option is enabled in the ZwaveJS Settings


I have checked and that is enabled.

The server host is set to ws://a0d7b954-zwavejs2mqtt:3000,
server port is set to 3000.
Disable DNS Discovery is set to off.

Above that, Disable MQTT Gateway is set to on.

I worked through the whole process again and got it working. Im still not sure where I messed up, but its resolved now.