Help with tasmota and mqtt power sockets

Tags: #<Tag:0x00007f73ae094448>

Hi there,

I recently flashed my 11 tuya smart sockets with the current Tasmota 8.3.1 image, In HA I installed the TasmoAdmin Addon. With Tasmo Admin I can switch every device on and off and everything seems ok.

Now, when I try to work with auto-generated mqtt switches in HA I get strange behaviour I just can´t explain due to little knowledge:

For Example a simple entity card:

type: entities
entities:
  - switch.tasmota01_office_kallax_led
  - switch.tasmota02_amy_malm_led
  - switch.tasmota03_flur_kallax_led
  - switch.tasmota04_test
  - switch.tasmota05_keller_pumpe_strom
  - switch.tasmota11_wohnen_kodi_strom

1.)
When I turn on for example “switch.tasmota01_office_kallax_led”, the socket turns on but also the state for “switch.tasmota02_amy_malm_led”. However, this switch hasn´t turned on (In TasmoAdmin, the state is off as it should be)

2.)
When I turn on “switch.tasmota03_flur_kallax_led”, both “switch.tasmota05_keller_pumpe_strom” and “tasmota11_wohnen_kodi_strom” are turning on as well, but not only the states, they really turn on.

And If I take a look into the logbook, it seems HA even tries to switch on some devices I don´t have physically attached right now.

30. Juni 2020
16:12:52 Kueche changed to Play
16:12:52 radio-kueche changed to playing
16:12:52 party led leisten turned on
16:12:52 party eingang open turned on
16:12:52 party eingang decke turned on
16:12:52 tasmota03 flur kallax led turned on
16:12:52 tasmota10 party led box turned on
16:12:52 tasmota08 party led leisten turned on
16:12:52 tasmota11 wohnen kodi strom turned on
16:12:52 tasmota05 keller pumpe strom turned on
16:12:52 tasmota07 party eingang open turned on
16:12:52 tasmota06 party eingang decke turned on

It sounds like these switches are in a group, but there are no groups defined in HA, these are all single entites, detected from the mqtt auto-discovery.

Do you have any Ideas where to look? Maybe is MQTT configured wrong either in HA or on the Tasmota devices?
If you need some config code, I´ll be happy to provide it here

Thank you
Philipp

You need to specify a unique mqtt topic for each device in the device’s config.

1 Like

Yes, thank you, you´re right. Just read in the docs from Tasmota. Strange, some had a unique topic definded (tasmota_%06X), the affected one had just “tasmota” as topic.