Help with Tuya Remote...Another TS0044 issue

I bought a TS0044 Tuya 4 button switch over a month ago, connected it through ZHA and it has been working great ever since, all 4 buttons working with all 3 of their functions (single press, double press and long press). Fantastic.

I woke up the other day to the device flashing like it was in pairing mode and it would no longer work.

I repaired the device and only 1 hour later the device went back into pairing mode. This has now happened 3 or 4 times.

Has anyone else had issues with the TS0044 disconnecting from ZHA and becoming unusable?

The particular model is the TS0044 by _TZ3000_wkai4ga5

Hi Panacus,

tried changing the battery?

Best
j

Yes, i have the same problem. Unfortunately I can’t re-pair anymore.

Are you using zigbee2mqtt integration? Can check what version? I’m running 1.25.2-1 and also facing the same issue.

Hello,
I have just bought 2 of these ts0044 4-button scene switch, and I face the same issue as you.
I configured them with Deconz (only the single press effective so far, but ok for me), but after one day, all 4 green diodes started flashing rapidly and it was not sending any command.
The documentation being very poor, I can but assume that this rapid flashing could be related to a low battery signal, but I was not expecting it to be out so fast.
I have tried changing the batteries but it is doing the same.
Maybe my batteries were were old, but before re-starting, has anyone experience this 4-Diodes simultaneous rapid flashing?

Thanks in advance
Vincent

The solution for me was to replace battery

1 Like

I’m experiencing the same behavior. Unfortunately, I don’t have a solution for this.
I used this switch without problem with Zigbee2MQTT.

Did it for me too. But in Z2M it stated 100% battery with the “old” one :man_shrugging:

So I just got here after searching as I have the 2 button variant of the device and I just came home today around lunch time and discovered mine doing this. I removed the device from Z2M, took out the battery, and the put the battery back in and re-paired it. And it’s working however the battery indicator is now not registering in Z2M or HA and nothing I do is returning that function.

Ugh, I just walked outside my office to find that it’s flashing again. Are these just really bad switches on battery life? I’ve only had it for like a month, and it’s not even used that much. I had to buy a pack of batteries for it since it didn’t come with any.

Update, grabbed my pack of batteries and replaced the battery in the unit and it immediately started working. I hadn’t been paying attention to my battery level card, and apparently my battery low notification automation isn’t working. :thinking:

I had the same. New battery. Lasted a month. I did pay attention to the battery indicator and it was still at 100%, so a low battery notification won’t do you any good. I find this really bad. I have a Philips Hue dimmer hanging next to it of which I recently had to replace the battery… after 4 years. This is becoming a very expensive device this way. Very disappointed.

Just had the same happen to mine. Bit annoyed if this is battery as it hasn’t been in operation for very long.

I tied reconfiguring and that failed, this is what the window shows:

and the battery section:

Screen Shot 2022-11-15 at 5.54.20 am

Would seem to indicate a battery issue. It reports battery as 100% though, so that’s unhelpful.

Same problem here. Have 4 switches, after a few months one by one changing batteries.

Using ZHA with conbeeII on a raspberry pi 4, latest versions usually.
(Now core 2022.11.2 operating system 9.3)

Hopefully someone finds a solution to this. The switches are very useful when they work.

Same issue battery keep flashing, one month GP 2430 battery. Will try buy a new one and try again.

Update, just replaced battery and everything back to function!

It is a pity that battery cannot last long on this remote, otherwise ot is really useful device.

The battery status is very suspicious with these devices, I think it is just hardcoded to return 100%. Mine ran its first battery flat in about 3 weeks, but was indicating 100% the whole time. My IKEA remote indicated 87% with another battery from the same pack out of the box, and is still there 6 months later (on its previous battery it got to 72% before starting to act up).

Sorry to necro-thread, but I wonder if some of the battery and pairing issues are related to a bug that I seem to have stumbled on when pairing a new TS0044.

I tend to rename devices explicitly in Z2M and make sure my HA devices/entities match just for my sanity’s sake. However, I noticed that if I named the TS0044 with anything that included a space (like I’ve done for my Aqara and Hue devices, the device becomes “unrecognized” or and many of the features become “unsupported” or “undefined”. I thought this was a temporary issue while Z2M reconfigured things and HA synced up, but it never did come back to a usable state after that.

The device would still report when a button was pressed, but would only report the following:

Received message from unsupported device with Zigbee model ‘undefined’ and manufacturer name ‘undefined’

However, if the device name was changed to replace all spaces with underscores ( _ ), then everything behaved as expected. Z2M came back online with all device states/info as expected and triggered functions also worked as expected.