Help with TV Media Player Googlecast etc

Every time I think I got a handle on things here… something brings me down to earth. Kind a l like when I played golf and then would always find myself in the rough.

I think most of my confusion is just all the different pieces that seem to control the same things but differently. There’s:


… and they all point to my TV in the family room!!! Some expose the same features. Some expose addition features. Some execute immediately and some lag.

media_player.dfamily_tv would seem to be the entity of common sense but often the other two entities often render exposures faster.

I can turn the TV ON and OFF.
I can change the volume on the TV.
I can NOT change the channel!!! It’s almost always “Not found Channel”

This is a SONY TV, running a SETTOP box for FIOS. I speculate the issue is somewhere in that setup but I would think it be a common issue for others too. But search here has not helped me find a working solution so far.

This is my current test code:

alias: Test Tv options
description: What happens with Tv

  • service: media_player.turn_on
    data: {}
    - media_player.dfamily_tv
  • delay:
    hours: 0
    minutes: 0
    seconds: 0
    milliseconds: 100
  • service: media_player.select_source
    source: HDMI 1
    entity_id: media_player.dfamily_tv
  • service: media_player.volume_set
    entity_id: media_player.dfamily_tv
    volume_level: “0.20”
  • service: media_player.play_media
    entity_id: media_player.dfamily_tv
    media_content_id: “510”
    media_content_type: channel
    mode: single

Everything seems to work up to the last step which I think should be a no brainer. But clearly I have no brain as nothing I have tried the last two days has worked for getting the channels to change to anything.

This isn’t a major issue, Just more hopeful someone has the simple answer on the top of their head.

As usual,
Thanks in advance for any help on my issue.