Help with VirtualBox + Aeotec zwave stick and Snapshot

I was trying to setup HassOS on a VM on my Mac with VituralBox. Everything works fine and HA is pretty fast.
But there are a few problem I ran into.

Old Setup:
Raspberry Pi 3+ with HassOS 1.12 and HA 0.81.0

  1. How can I detect the my Aeotec Zwave USB Stick and add to the VM? Its looks like, the Stick ist not detected correctly on my Mac. HassOS v1.11 should work with the Stick but I’m really not sure how. :weary:

  2. I tried to restore my HassIO Snapshot from my Raspberry installation to the VM.
    I made a full restore. The process runs without any error. But after restoring, all Hassio Addons a installed and Setup correctly, but the whole config is NOT in the /config folder. Just the default config. I tried it a few times. How is this possible?!? I’m also a little bit afraid if the Snapshot and restore process is working on my Raspberry it something went wrong.

Thanks for helping.

I’m one step further.

  1. My Zwave Stick is now detected. I have to added the Stick in the VirtualBox Settings under Port section. The zwave stick called “Sigma Designs”. Then go in the CLI login with root. Type “hw info” and see the USB stick unter Serial.
    Mine called “ttyACM0”. Add this to your configuration file.

  2. I found out. The Snapshots done by the Pi Hassio are corrupted. It is curious because I made 3 snapshots and only one are working correctly. The working one was only 400 MB and the corrupted are 700 MB. I have dearchived the damaged ones and the .tar with the configuration files is not working.
    Why did this happened? I’m a little bit afraid of my Backup strategy, if the Snapsshots are not working correctly?!?


Oh man did you made my life so much easier today. I could not get my z-wave stick working until I read this post.

Thank you

1 Like

Story of my life. Because of this I bought an Intel NUC on WIN10, using Virtualbox with the downloadable VDI image to run Hassio. Backing up the VM works a lot better!

Just wondering if you did anything special for the Zwave stick. I was able to get it running on my Windows 10 machine under VirtualBox but I would keep getting USB disconnects

[16075.886832] usb 2-2: USB disconnect, device number 3

I followed several tutorials to make sure Windows dosen’t put the USB to sleep but I coulodn’t get it to work so I had to switch back to my Pi :frowning:

Hello, I am attempting get virtual machine to discover the Zooz(Aeotech) Z2 Stick on an Ubuntu 20.04 host. I can see it with lsusb. but it will not automatically discover it or work when the filter is manually entered in the vbox settings.

Hello Guys, I am also facing the same issue, i spend my last 2 days trying to make this work but unfortunately i had 0 luck…

I am running Ubuntu, latest version, installed VirtualBox and under Serial port COM1 is selected, port mode is: Host Device and path/address set to /dev/ttyACM0 as it shows in my ubuntu terminal.

Can you please tell me what am doing wrong? really appreciate. thanks!

LE: I was able to install extension pack for VirtualBox, added my local ubuntu user to vboxusers and the devices started to show up in USB.

However, when i input the path in Serial ports and try starting up the machine , i get a fatal error and can’t start the machine.