HELP! Z-Wave nodes/entities missing after upgrade 0.94.1 / downgrade not possible?

Tags: #<Tag:0x00007f3f1bfdba40>

Hello, I’m at a loss here. For the past 2 days I’ve been trying to get the Z-wave identities back. After an upgrade tot 0.94 (and 0.94.1) only 1/3 of my z-wave entities are recognised. I’ve several backups of the zwcfg_*.xml

What I’ve done:

  1. Stop HA, remove zwcfg_*.xml (which is then only 1/3 of the actual size!),
  2. Restored a backup of the zwcfg_*.xml
  3. Renamed .storage to .storage.old
  4. Tested with 0.93.X and 0.94.X

But only 1/3 of the Z-Wave nodes (and entities) are in the Z-Wave settings.

How can I restore a working version with a all nodes? Seems like the Z-Wave upgrade in HA is not working correctly.

1 Like

Can you restore a snapshot of the previous version and see if they return?

At least then you will have a new good starting point.

I had some missing entities on upgrade. I resolved the issue with approximately 3 restarts and they then were back.
With many upgrades it is always wise to do a number of restarts first before trying anything else. I would say after 5 I would then investigate other options.

I’ve restarted a lot more than 5 times. I’ve deleted the whole Z-Wave integration (and entities), reset the Z-Wave stick and started to add all nodes again. I’ve wasted almost 2 days without any resolution. This has not happened during the 4 years with Z-Wave for me.

1 Like

Just adding to the frustration here. Same thing. Everything working fine, upgraded, now every reboot is a dice roll for Z-wave devices. Sometimes even the controller won’t show up.

Oddly enough, some things show up but then the automations and buttons (mostly for light switches) don’t work. So the entity is there, but everything referencing it can’t find it.

This is really pushing me to downgrade and then never upgrade. Similar things happened on my last upgrade and the Hass.io snapshot was useless to get things back where they were. I can’t be adding all the devices from scratch every time HA upgrades.

1 Like

Are you waiting enough time for the zwave network to initialize after reboot? It can take upwards of 2 minutes.

Yes, I am. Last time (just a few minutes ago), I got everything except one battery sensor. I woke it up and tried healing, that didn’t work. So I tried a restart. The log shows the stick communicating with all my devices one at a time with responses, but none show up in HA. Just the controller and even that doesn’t show it’s name and brand like normal.

So I think the Aeotec stick to device communication is fine. It’s how HA pushes the config data and populates its database entries that is failing.

1 Like

have you ever mapped your zwave network and found the devices that have trouble communicating? If you’re getting 1 or 2 failures on battery devices, chances are hardware issues not software. I.E devices are having trouble communicating based on range to network. I have 5 battery devices in my network of 60+ devices and it connects everything all the time. The battery devices are smack dab in the center of my network. It’s also worth noting that most battery devices do not add to the mesh, they just communicate with it. Meaning messages do not travel through them, they only act as an endpoint node.

I have not, but I have learned how to read the log and find node status. In my case, I see communications with Nodes 3 and 5 (my 2 battery sensors) with replies. They seem to talk to the controller, announce what they are, and the controller provisions them as non-mesh devices (I forget the wording, but it was clear they weren’t repeating the Z-wave messages). So it looks like comms are good to them – they just aren’t showing up in HA.

The other weird thing is sometimes switches show up as a node and Z-wave device (zwave.DEVICENAME), but the switch.DEVICENAME never populates so the automations and buttons don’t work. But on the Z-wave panel it’s there and ready. Weird.

I want to stay at this current rev as it has some integrations I was waiting for, but man it is frustrating to have such wacky behavior on every reboot.

1 Like

You might try posting a copy of OZW_Log.txt when this situation happens.

Have you tried disabling modemmanager?

If you are actually rebooting the host (which is different from restarting HA) make sure you save the config (control panel -> Save Config) beforehand, otherwise newly added nodes will be missing from the cache file (which is only written on HA shutdown or Save Config).

Thanks. I will look into modemmanager. No idea if it’s active.

I got the system semi-stable with everything except my garage door sensor (battery). That one might be signal-related. I bought a couple of plugs to put around the house more as repeaters. I had to move the server to the basement; which orignally worked fine, but now that I’m seeing weirdness I want to make sure the strength is up.

Is there a way to read off signal strength on the nodes? Didn’t see it in the logs, but I only briefly looked at it.

And to tie into the oringal post – I haven’t done anything other than reboots to get most things back, then I saved the config and now things either don’t boot at all (no Z-wave controller even), or I get everything except the garage door, which I remove and re-add easily enough. Odd thing is, they are still in the xml file, just for some reason it didn’t complete “registration” on the bootups. I’m hoping signal strength solves it.

Mapping your network should show the strengths by looking at the latency

Awesome. Thanks. I’ll look at installing that tonight.

Installed and mostly working. Great tool for seeing network latency and battery power. It helped me “site” my plug in module, which I really only got as a range extender.

Spent some time cleaning up things and now have everything back (needed to re-add one node and force-remove a duplicate). Saved and backed up so hopefully won’t have to go through this again especially since the network is growing.

Thanks for the help.

1 Like

Oh, and I disabled that modemmanager – much more stable now. All Z-wave devices come up at every reboot. Thanks for that.

1 Like