Help - Zigbee2Mqtt acting weird - related to HA 2023.10.2?

So once in a while my zigbee goes weird.

This is what happens:
The add-on seems to not be ready, it might still be starting. Do you want to try again?

It seems like 1 device cause this issue and goes weird. It is:
TS0601 (AVATTO ME167 control via MQTT | Zigbee2MQTT)

some logging:

What is this? What could be wrong?

The logging is taken from the addon logging (in HA). This logging is not in z2m to see in debug level mode.

It seems like z2m is working but terribly slowed down hence not able to show the interface about 50% of the time. Restarting addon does not help.

So sometimes I get:

Then a black screen only and then it works…

And it seems like it is in that order everytime :man_shrugging:

1 Like

I don’t know what the problem is, but I doubt that one device can slow down z2m. I personally never experience this and have 80+ zigbee devices. It most likely some problem with a coordinator or z2m config.

My guess is that the device is spamming the radio until it crashes the coordinator causing the add-on to crash.

Can you try to capture the add-on logs when it happens?
Settings → System → Logs → Select Z2M from the dropdown in the upper right-hand corner.

I think the addon logs are equally changed with the log settings in z2m itsself correct? What should I log? Info, error, debug, other?

now set like this:

The logs:

I am not 100% sure but I think it does not seem to influence the control of the devices (or restarts of the addon is fast)

Can it possibly have something to do with the recent ha update to 2023.10.2? Something with ingress to the z2m container? It’s so weird that it never happened this way before and nothing really changed. Also as it seems that it does not affect the functionality (not I can notice at least)…

Edit: I resetted that one device and that logging is now gone, but the issue persists…

1 Like

Hello, I had same issue with Zigbee2MQTT UI. I got all the readings from my sensors, so I didn’t notice that one of my automation does not work until my wife told me (light toggle based on motion sensors). After reading your post I revert back to: core_2023.10.0 and everything works again.
BTW: DO NOT FORGET to create a new backup of your current setup if you changed something between updates :wink:

1 Like

I’m having this same issue after updating to 10.2 and a similar issue happing with zwave js ui that started at the same time.

Related to HA core 2023.10.2 it seems.

The issue is being worked on actively - see GitHub issue tracking:
Downgrade aiohttp to 3.8.5 by frenck · Pull Request #101913 · home-assistant/core (

So more to come, I suppsoe.

1 Like

Marked as solution :-), lets hope it is (will be).

Solved! After update to 10.3