Helper for input entities disappear when disableling

When I use a Helper to define my Inputs I do this to have these not defined in my config.yaml. It is pretty neat but i found one thing very anoying: If you disable the enitity you cannot get it back. See this picture:

At least I can’t;
So two questions.
Is this a bug and if so where should I post this;
Is there a way to find the yaml code back. For me it would be perfect if in the config folder a subfolder helpers had been created with the code in it.

I don’t use the helpers UI but if they are anything like the entities list there should be a filter button to the top right of the helpers list that looks like this:

Screenshot_2020-06-03 Configuration - Home Assistant

Click it and tick the show disabled helpers option.

Hi Tom,
I re-checked this but sadly the icon is not there. I tested in Chrome, Firefox and Edge.


You should open an issue then:

Hi, just happened to me as well, I cannot find a helper I disabled, it disappeared

SOLVED. You have to go to /config/.storage/ and edit the file core.entity_registry. Find your entity, there will be

                "entity_id": "input_boolean.pc_living_room",
                "config_entry_id": null,
                "device_id": null,
                "area_id": null,
                "unique_id": "pc_living_room",
                "platform": "input_boolean",
                "name": null,
                "icon": null,
                "disabled_by": null,
                "capabilities": {},
                "supported_features": 0,
                "device_class": null,
                "unit_of_measurement": null,
                "original_name": "PC living room",
                "original_icon": "mdi:desktop-classic"

change "disabled_by:" user to disabled_by": null

Reload or hard reload did not work. Restart HA core did work for me. Then the helper reappeared.


I’ve created an issue:


Note that one way you can get a disabled helper back is to go to the Entities tab, not the Helpers tab.

While disabled helpers are not visible in the helpers list, all helpers are also entities, so they appear in entities list. If you set the filter for entities to show disabled, then you can find your disabled helper in the list. Then you may click on it to bring up the configuration, and change the radio button back from disabled to enabled.

Editing the .storage should not be necessary.


For all fans of pictures: here is the key element you have to trigger first:
show disabled entities has to be activated first

only then you can see the helper / input number in this case the 4th line to activate later