HEOS integration: heos.sign_in stopped working yesterday

I have a Denon HEOS speaker that HA always turns on via automations. It always works perfectly.
Since yesterday all of a sudden it doesn’t.

The heos.sign_in service now suddenly fails:

Failed to call service heos/sign_in. ‘NoneType’ object has no attribute ‘write’

Afterwards I tried updating the Heos speaker firmware. It does not solve the issue.
Could the integration be broken? Perhaps Denon changed their service?

The service data is unchanged:

    "username": "[email protected]",
    "password": "password"

Also I verified that the ip-address mentioned in configuration.yaml is still correct.

Still working for me :roll_eyes:

It was likely a bug in 0.106. I just upgraded to 0.107 and it started working again.

It failed again after I upgraded to 0.107.4. Now I went back to 0.107.1 and it worked again. Could in theory also be random behaviour, I’ll stick to 0.107.1 for a couple of days before upgrading see what happens.

Hello, since version 0.108.8 I also have no connection to my Heos AVR. He is successfully found in the integration. But I can not register through the Sign_in service. No log entry is created. As well, no entity is created for the media player. Can you help me? Thank you.

I haven’t encountered any issues anymore recently.

I have this problem regularly “object has no attribute write” when trying the heos.sign_in

I just had this message again today. And this at a moment that my Heos was playing music from the app without any problem.

I rebooted the host system. And I could sign-on without any problem.

Until now, I don’t understand what is the origin of this problem.
Who has understood the problem?

I encounter the same issue. No response from the media_player. Tried to execute heos.sign_in via development tools, but no luck

I think currently there is another issue this evening that is unrelated to Home Assistant.
Try opening the HEOS app on your phone. For me the options listed are only local ones. Internetradio etc is for example not listed.
If I try to go to my ‘favourites’ in the app (which contain some internet radio stations, the denon app pops-up an error:
Unknown error
Unknown error occured (error code -2000). Please try again.
In home assistant I got the same errors in the logs: “Unable to update sources: System error -2000”

Strangly the issue is gone after restart of HA

I’m having a different problem today.
The HEOS app is working without any problems, however my devices are ‘unavailable’ in Home Assistant.
I get these warnings in the logs:

  • Config entry for heos not ready yet. Retrying in 5 seconds
  • Config entry for heos not ready yet. Retrying in 10 seconds
  • Config entry for heos not ready yet. Retrying in 20 seconds
  • Config entry for heos not ready yet. Retrying in 40 seconds
  • Config entry for heos not ready yet. Retrying in 80 seconds

Does anybody have the same issue at the moment, or any tips for solving it?
I also have a Denon AVR which I usually control with both the HEOS integration and the DenonAVR integration. With the HEOS integration it is unavailable but the DenonAVR integration is working.

EDIT: removing the HEOS integration altogether and then adding it back solved the problem. Strange but happy to have it back because the HEOS and DenonAVR android apps are terrible!

Hello all,

I am trying to connect my Home Assistant with my HEOS account. But unfortunately without success. I always get an error message in the Log that the service was not found.I have entered the data according to the documentation under services (see screenshot). I have entered the data according to the documentation under services (see screenshot).

Does anyone know what I’m doing wrong?

Logger: homeassistant.helpers.script.websocket_api_script
Source: helpers/script.py:1310
First occurred: 18:27:00 (1 occurrences)
Last logged: 18:27:00

websocket_api script: Error executing script. Service not found for call_service at pos 1: Unable to find service heos.sign_in
Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/connection.py:131
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 18:27:00 (1 occurrences)
Last logged: 18:27:00

[140600922435888] Error handling message: Unable to find service heos.sign_in

Hi, I changed my Heos password last week. Tried to call the heos.sign_out service without success.
It seems I don’t have the Heos services.

I tried removing the integration, restart HA and installing it again. But the wrong credentials are still cached.

Any ideas anyone ;(
My kids NFC music box is dead without the heos integration :slightly_frowning_face:

It’s fixed in 2022.9.7 :slight_smile:

1 Like

Same problem again. Service has disappeared. No heos.sign_in.

Weirdly if I goto yaml mode and enter this;

Then flick back to UI mode, I get an updated description of the service that doesn’t exist


But if you call service;
" Failed to call service heos.sign_in. Unable to find service heos.sign_in"

I have problems with the heos integration all the time. It is trying to initialize all the time.
Also the heos.sign_in service does not exist. And I get an error about heos.signin (no _) in the logs that I have no clue where it comes from.
Please help.