HEOS stopped to initialize after recent update

After recent update of one of component (not HA itself, it was either OS or Supervisor - ~2 days ago) HEOS integration stopped to initialize for me. It shows following error in Integrations panel:
image
and following error in log file:

2022-12-30 12:42:35.899 WARNING (MainThread) [homeassistant.config_entries] Config entry 'Controller (192.168.52.47)' for heos integration not ready yet: System error -9 (12); Retrying in background

Anyone experiencing the same?

Same her, I just set up HA a few days ago (HAOS on Odroid N2+) and I can’t get HEOS integrated as the error above shows up. We have a Denon XVR-4400H (with integrated HEOS), one Denon Home 350, three Denon Home 250 and two Denon Home 150. All seven devices are detected with their correct HEOS name, but when I select one of them, I get the “Retrying setup: System error -9 (12)”. I also have exactly the same log message as @mirekmal (bar the IP address).

I am logged into my HEOS account both on the app and on the AVR. I deleted the integration and unplugged and replugged the AVR and turned it on, source set to “HEOS” (although I think it should work even if off). When I then add the integration manually, I need to specify the IP address, and I then get a different error: “Retrying setup: Command timed out”. Log also gives a slightly different entry:

WARNING (MainThread) [homeassistant.config_entries] Config entry 'Controller (192.168.51.90)' for heos integration not ready yet: Command timed out; Retrying in background

Did you manage to solve this already?

In my case hard restart of the devices helped to solve the problem. By hard restart I mean not just power cycling, but physically disconnecting them from power for 15 seconds and then powering on again. Working fine since then. I found this solution in other HEOS related thread, so apparently it is not so rare to happen.

1 Like

So yesterday, after I wrote my post, the integration at some point connected. Unfortunately, I realised that the AVR was missing as an entity, presumably because it happened to be grouped as a slave with one of the Denon Home 250 in the HEOS App. So I deleted the integration again, ungrouped the two devices in the HEOS app, added the integration in again and kept it retrying for 12 hours or so. No luck.

I have tried the hard restart for the two devices I tried to use as a master to no avail. Tomorrow, I will unplug all seven devices at the same time, then plug them in again and then try to add the integration again. I will report on results.

Still no luck.

I finally unplugged all HEOS devices at the same time and plugged them in again (making sure no speakers were grouped in the HEOS app). I restarted HA and it auto-detected the HEOS integration as before. I then selected “configure”, and then only 5 of the 7 devices were shown to be selected as the master device. I selected my Denon Home 350, as this is always on and always connected by a network cable.

Eventually the integration worked - but this time, only the Denon Home 350 is shown as a device or media player entity. The other 6 HEOS speakers are not shown as devices or entities. Is there a way to add them manually after the initial configuration?

By the way, all seven devices are auto-detected as part of the “Denon AVR Network Receivers integration”, but I don’t think this is what I want.

Progress and maybe solved!

So since my last message three weeks ago, there were always different HEOS devices shown as active, usually two or three out of the seven HEOS devices we have. I could not see a pattern. It was still wrong yesterday evening (after an update of HA Core).

Today, the HEOS app on my phone was updated, and, when going into the settings, also a firmware update for all seven devices was offered. I applied this firmware update, restarted HA, and - voilà - for the first time, all seven HEOS devices are shown. So finally, I can check what I can do with the integration. :slight_smile:

It therefore seems that there was indeed a problem on the side of the HEOS firmware, and not with the integration. I’ll report back if any issue re-occurs.