Hi can anyone help me with my problem? I downloaded Waste Collection Schedule and cant configure it

so i am just starting out with home assistant and exploring different stuff i have downloaded waste collection schedule and was looking for exact help to configure this and where i am to put the information , i found the information from my local council and have included this but i cant make sense of the instructions of where to put this. step by step by step detailed instructions would be very helpful.

waste_collection_schedule: sources: - name: tameside_gov_uk args: postcode: “OL7 9HH” uprn: “100011538499”

If you’d follow the link on the main page of the repo then you would end here… i.e. configyaml to edit (and restart HA)

hacs_waste_collection_schedule/doc/source/tameside_gov_uk.md at master · mampfes/hacs_waste_collection_schedule (github.com)

I’m sorry but I don’t quite understand , I got into what I think was a configure yaml file but can find anywhere that this would go , I’m sorry but I am completely new to this and I am still trying ti learn it but no where in the yaml file looks like that that they want me to put in .

In your home assistant installation directory, there are a lot of files, one is named configuration.yaml

Open this file with a file editor of your choice and add the section mentioned in the link provided by vingerha.

    - name: tameside_gov_uk
        postcode: "OL7 9HH"
        uprn: "100011538499"

You have to be careful with the indentation, that means that every space is important in yaml.

   postcode: "1234"

is not the same as

postcode: "1234"

Thanks for your response , so can I add this anywhere in that file ?

yes, but not in the middle of another section :slight_smile: (a section is always starting at the beginning of a line, like here the waste_collection_schedule:

This is my config.yaml file so I just put that information there on 12 ?

yes, add an empty line, more readable

I have this error when I go to restart , have I done something wrong ?

Try to restart anyway.
HA can not validate a custom integration before a first load.
At worst you’ll have an error in the notifications.

1 Like

i did the restart anyway and i did have the error saying invalid config

sorry i have just deleted and reinstalled the integration and tried again and it has now worked thank you for all your help and patience.

You’re welcome.
Please mark one post as the solution so people will know that it is closed.

1 Like