High Accuracy Mode disabling while in defined zone

Hey everyone,

I’m having problems getting high accuracy mode to enable and stay enabled for as long as it needs to be for some of my arriving home automations to function.

I’ve both used my Home zone with a trigger radius and a new defined zone without a radius and neither performs as it should.

I’m using a Pixel 6 Pro with location services enabled, Home Assistant allowed to gather location information in the background, and high accuracy mode enabled with the “only when in zone and BT device connected” toggle enabled. The latest version of HA core and the app are installed.

I’ve tried a few different scenarios and none of them consistently work. The problem always seems to fall into zone detection failing in some manner. My overall goal is to use passive zones to trigger an automation turning lights on and opening a garage door when I arrive home.

Scenario 1: Only zone in Home Assistant is Home. App set to enable high accuracy mode when within 1500 meters of Home zone.
Result: High accuracy mode triggered immediately after leaving home zone. Did not turn off again. Went ~5,000 meters outside of Home zone. Waited for logs to show next LocBroadcastReceiver messages.

LocBroadcastReceiver: High Accuracy mode enabled, because in zone [2_zone.home_expanded]

Scenario 2: Adding passive zone for triggering automation. App set to enable high accuracy mode when within 1500 meters of Home zone.
Result: High accuracy mode never triggered. Went outside zone and logs showed “not in zone” as expected. Came within 500 meters of Home zone and waited for next LocBroadcastReceiver message.

LocBroadcastReceiver: High Accuracy mode disabled, because not in zone [2_zone.home_expanded]

Scenario 3: Added new zone just for activation of High Accuracy mode, overlaps with home zone. Set app to enable when within 1500 meters of zone.
Result: High accuracy mode never triggered. Same results as scenario 2, with different zone name in log message.

Scenario 4: Same as scenario 3, but disabled app trigger radius so high accuracy mode is triggered anytime in zone.
Result: High accuracy mode never triggered. Parked on the exact coordinates of the center of the zone until next LocBroadcastReceiver message arrived. Message said “not in zone”.

Scenario 5: Same as scenario 4, but setting the trigger zone to not passive.
Result: High accuracy mode triggered upon entering zone, but when entering passive zone used for triggering automation, high accuracy mode disabled saying “not in zone”.

I don’t know why the app never thinks I’m in a zone, or in the one time it did trigger successfully, why it never thought I left the zone. I’ve also deleted the app to reset it completely, and that made no change in results. There doesn’t seem to be any consistency, and I really don’t want to have the only trigger be that I’m connected to my car bluetooth alone.

Edit: Of note, if I do just leave high accuracy mode on, the automation triggers as designed, but without it there’s no way for me to be detected within the zone how I need to be to allow the automation to run.

I’m having the exact same issue. High accuracy turns on when exiting zone.home but doesn’t turn off after exiting zone.home_expanded. It then doesn’t turn on when entering zone.home_expanded from a non defined zone.

I’ve tried like you have a full android app reset as per trouble shooting docs and even set up a new home Assistant server on a new device but the issue still remains.

I ended up creating some automations to command high accuracy based on a proximity sensor I created. It seems to work some of the time but because mobile reception around home is patchy it can be delayed in turning on high accuracy mode.

1 Like

known issue, workaround mentioned above for using the notification command is a good idea here until solved