High CPU (50%) HAOS 10.3

What is the CLI command to run top or htop or iotop?

Can it be run from console or do I have to enable SSH?

How to enable SSH?

I believe ‘htop’ will work on Debian and it should be able to be done in console,




OK, so HAOS isn’t Debian - sorry, I missed that although I can now see you had it in the title.

Indeedy :slight_smile:

I had it at 2 CPU, noticed today it was running at 50-60% utilization.

I have literally nothing but NUT running.

I disabled all addons, no change.

I rebooted, no change.

I’m at a loss/confused.

Need granular report of PID to figure out further.

Well… installing the SSH/Terminal add-on worked.
Not fond of a workaround, but hey I can look at stuff now.

I have a Debian container (12 IIRC) I could run HA-Core in just to see what’s up with the config.

Have you installed ‘system monitor’?

Run glances in unprotected mode to get a full picture of what’s going on. For me, this always comes down to the haasio_dns container maxing out one or more cores when it can’t phone home. If that’s the case for you, you’ll need to disable fallback dns.


1 Like

Just did, neat history, tho I have it already with XCP-NG so not all that helpful.

Thanks, I will try that!

Thank you!

That was the fix.

ha dns options --fallback=false