High CPU load after installing ha-rpi gpio integration [Solved]

Today I installed a fan to my Raspberry Pi 4 to keep it cool.
To automate it I added the GitHub - thecode/ha-rpi_gpio: Home Assistant Raspberry Pi GPIO Integration using HACS. Everything works and it was easier than expected. I however noticed a serious increase of CPU load and utilization as visible in the 15m load graph below.

And the CPU usage/utilization (added in the edit)

I searched the community but could not find any post about it. So I am wondering, are there more people experiencing an increase on CPU load after installing the integration?
If so, is there something I can do about it?

Current versions
Home Assistant 2022.10.0
Supervisor 2022.09.1
Operating System 9.0
Frontend 20221005.0 - latest

ha-rpi gpio version: Latest stable version


      - platform: rpi_gpio
          - port: 14
            name: "PI CPU Case Fan"
            unique_id: "cpu_fan_port_14"

Well, problem solved. It was not the ha-rpi gpio integration.

The problem was caused by the not configured Matrix add-on. The add-on was not in use/running, but was set to start at boot. So after I mounted the Fan and booted the Pi, the add-on started.