High disk usage

I am experiencing ever decreasing disk space on my Home Assistant OS instance running in a Proxmox VM in Intel Nuc.

My snapshot sizes are 1.2GB which are created every day and I have a script enabled to prune those on a regular basis. However I still can’t figure out what is eating up al my HD space.

Currently after cleaning old snapshots I have 27.5GB in use.

As you can see in my Grafana dash this is decreasing every day with a few GB’s

I have tried to find the culprit using du however I can only find 12GB of diskspace this way:

Anyone have some clue how I can find which process is responsible the other 15GB? And how I can resolve this issue.
This will already become an issue in a few weeks. And 64GB should be more than enough for even a extensive Hass installation as I read through the forums and documentation.

1 Like

I’m having exactly the same issue just now in a proxmox VM. I haven’t had time to delve into it but wondering if there’s a bunch of old docker images lying unused or something.

1 Like

I’m using MariaDB and just yesterday I figured out that I hadn’t enabled auto purge in my recorder settings. I was able to shrink my DB from around 20 GB to 7.9 GB (keep 30 days)

Thanks. I am also using MariaDB, but did check the DB size yesterday and it was very small in my case. I am not at home atm so cannot double check it. Will have another look tonight.

Another thing I figured out was that updating or deleting add-ons sometimes doesn’t remove the image of the add-on. The easiest way you could chech that is using Portainer.

Thanks I will install portainer to check if I have old images.
Also I found this addon/forum post to setup ssh key access on the host system. Not sure if this will work on virtualized Proxmox environment. Maybe than I can see all processes and utilized disk space.

I’m on the pi image, portainer gives you the same access as port 22222

1 Like

I installed portainer and see I have 20 images taking 6.3GB. Not really any obsolete images.
Will monitor the next days to see if I can figure out some patterns when the disk spaces increases with large steps.

Reviving this topic as I do not see a resolution and my proxmox install is doing the same thing. ever increasing size until finally it bombs… did anyone find a way to stop this?

I didn’t find a way to stop it, but after 2 years I figured it was time to just spin up a new VM.

Step 1. Exported a backup of my current HA install to my local PC.
Step 2. Import a new VM using the instructions from this post.
Step 3. Shut down old HA VM & new HA VM.
Step 4. Copy network settings (IPs & MAC Add) and CPU/memory settings from old VM to new VM.
Step 5. Transfer any passthrough hardware from old VM to new VM.
Step 6. Start new VM.
Step 7. Import backup from step 1 on first login and wait until it completes.

Restoring the backup took over a half hour but everything worked flawlessly. Keep your old HA VM for a couple days in case you spot any issues and have to revert back. My HA disk space went from over 200GB (after cleaning old backups) to about 60GB. It’s kind of a kludgy fix but even doing it every couple years is nothing compared to the work I had to do to keep Hubitat stable.

thanks for the update. yes recently i ran into an issue when updating ha, it froze and proxmox had run out of space. I did have a backup and just reset the proxmox, deleted old HA and reinstalled a you said. Works fine, but I feel like i will again run out of space in a month or two at the current usage… maybe I will find what is going on, or I just have to spin up a new one when necessary. thanks again.

Sounds like you need to do some work on reducing your database size by using the recorder settings. Even 60gb is far too large a backup size.

I’ve got my VM happily running in a 32gb disk and backups are under 2gb.

1 Like

To clarify, the 60GB is the space used on the disk, the backup images are around 10.5GB which is fine. Disk space was north of 200GB before I redid the VM, now its a little over 60GB… That shows that there is some undetectable growth in space used happening somewhere.

History is 14 days and I have a lot of filtering configured… I just have an incredibly large system. 300+ Zigbee/Zwave devices alone.

I managed to get 2 years before the growth got out of hand. How much space did you allocate for your VM?

have same problem, 01/2023
after install update from HA , VM in proxmox failed and i have 100% usage
what can i doo that helps for future also ?