High sensor voltage causing issues on Zigbe2MQTT+Yellow network only?

Hi everyone.
I’m having an issue with a Sonoff SNZB-02 temperature and humidity sensor. I have rechargeable LIR2450 batteries, but when I recharge them they end up around 4v. I noticed these sensors don’t work when the batteries are over ~3.2v, so I have to charge AND discharge the batteries before replacing. This is not an easy process, it involves some hit and miss. And sometimes after replacing the battery I have to re-pair the device.

I have two Zigbee networks, one with Zigbee2MQTT with the integrated Zigbee antenna in the Home Assistant Yellow, and a second network with ZHA with a Sonoff ZBBridge Pro.

Both SNZB-02 were paired to the Zigbee2MQTT+Yellow and working generally fine. These days, I had to replace the battery of one of the sensors and after replacing, it wouldn’t update its values on Zigbee2MQTT+Yellow. The battery would still show up as 0% and the temperature and humidity values were stuck in values from a couple of days ago. Even after unpairing and re-pairing. I also tried power cycling the Yellow, with no success. I was able to unpair and re-pair but the values weren’t updating.

I then tried connecting this failing sensor to the ZHA+ZBBridgePro network and it gets all the values perfectly, the battery shows up as 100%, and values are updating fine.

I then check the battery with a volt meter and noticed it is at 3.7v, which is over the “working limits” I defined in previous tests. This is clearly because I didn’t discharge it “correctly”. But this is new info: The sensor works fine on 3.7v paired to ZHA+ZBBridgePro but doesn’t work on Zigbee2MQTT+Yellow if it is over 3.2v.
I then put another battery which is measured at 3.1v and the sensor now connects to Zigbee2MQTT+Yellow, it updates its temp+humi values, but the battery shows as 10% (!?).

I am using two separate network because of some compatibility issues I had with a couple of old Philips Hue lights. I am thinking of migrating these sensors to the ZHA+ZBBridgePro network, but still, what is happening here? Does this make sense? Can anyone think of what is causing this weird behaviour? I don’t think it’s interference because I tried unplugging the ZBBridgePro during the tests.