Higher CPU Usage KVM/QEMU on host vs virtual machine

I switched to KVM/QEMU vs docker supervised. I’ve noticed that the host machine shows 20-30% cpu usage by qemu-system-x86_64, but the virtual machine is uses less than 5%. I found online that making these changes to the config can help, but they did not help.

  <clock offset='utc'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <timer name='hypervclock' present='yes'/>

  <!-- after: this config drops to about 3% of a host CPU core -->
  <clock offset='utc'>
    <timer name='hpet' present='yes'/>
    <timer name='hypervclock' present='yes'/>

Home Assistant runs fine, but I’d like to reduce the host OS cpu. This is the only virtual machine I’m running.

What can I provide to help?


Got the same problem running homeassistant-ova on debian 11 in kvm/qemu/libvirt.

Any update suggestions on this?

1 Like

I see the same thing too… I’ve tried to assign 8GB of RAM, and 4 VCPUs, but Home Assistant continues to suck down RAM…

I tried the clock suggestion from @patmann03 … But it’s still so slow and so laggy…