Hik-Connect integration

receive this (I put my passwrod),maybe other port, which?


io18:~$ curl -i --digest -u admin:xxxxx -X PUT -d '<RemoteControlDoor><cmd>open</cmd></RemoteControlDoor>' http://192.168.1.53/ISAPI/AccessControl/RemoteControl/door/1
curl: (7) Failed to connect to 192.168.1.53 port 80: Connection refused
[email protected]:~$

No, isapi should be on http port… What doorbell do you have? Maybe you turned off http service?

audio18:~$ http://admin:[email protected]/ISAPI/VideoIntercom/callStatus?format=json
-bash: http://admin:[email protected]/ISAPI/VideoIntercom/callStatus?format=json: No such file or directory
[email protected]:~$

Someone else confirmed that the command also worked on : DS-KV8113-WME1

DS-KV8202-IM Villa door station EDIT CHANGED 8202

not sure if/how to change http availability

Can you check if http port is open? Maybe the command is different on yours… You need to check specifications if your doorbell supports isapi

@Klagio i edited my post with the command to open door, seems something went wrong with copy paste… You also need to send that XML too

Another person confirmed door open command…

I have Hik cameras, but block them from access to the Internet, and I dont use Hik-connect. If you are concious about security in any way, then you may want to do a little research on Hikvision before connecting an instance of Home Assistant to the Hik cloud.

That’s we want a local option, we don’t have to use Hikconnect all, all can be done with local commands, like mine example to open a door

But for now, for people with an Hikvision intercom , hikconect is the only way to answer a doorbell… Or another possibility is to setup a PBX Sip system, but quite an overkill for a doorbell

I am lost, which is the correct curl?

Dangerous?

Not dangerous at all :slight_smile: , it’s all local…

But maybe your doorsystem doesn’t support isapi…
Have you checked if port 80 is open?

Guys, i changed thread here , with first reply, maybe we can discuss on that thread, then its all combined

first post is all about working commands, any feedback is appreciated, so i can update it

I already have how to set the call button in freepbx, kv8113-m.

yes, i tested freepbx too; i worked
but the disadvantage, on the inside intercoms/sip clients, there was no early video, so you dont see who is calling, untill you actually pickup

Hello, how to set the call button? Do you have a screenshot of the web interface? I want to refer to it.

i did enter my pbx like this :

then define the number you want to call on the keypad

for me on KV8102-IM also this command to open door not working.
curl: (7) Failed to connect to 192.168.xx.xx port 80: Connection refused