Hildebrandglow - Smart Meters - SMETS2

Hi

I was very interested in getting an output from my smart meters which are both SMETS 2 into the HA dashboard. After reading a few topics on here I found the use of this one which seemed ideal. So I have installed it … and the Bright mobile app.

Found a few problems with the mobile app but the support from Glowmarkt is fantastic … helpful and very responsive.

However I still cannot get the Hidlebrand glow integration working , no sensors are being created.

I am going to try using the MQTT method , but I wanted to see if anyone else as tried the integration without MQTT and got it working ? If so any idea what I can check as the repository setting is correct and its authenticates with Glowmarkt fine ?

Thanks Andy

What exactly is happening when you say its not working?

Are you using the right App ID when you setup the integration? see github issue #15 if not - https://github.com/unlobito/ha-hildebrandglow/issues/15

Hi

yes I think I did but to be sure I reinstalled the repository via HACS and restarted HA .

I then deleted the Integration and re-installed making sure I used the App ID from the link you posted.
Just to be sure I restarted HA again but still no entities created.

I also checked that all the components listed are in the “config/custom_components”

So not sure what I’ve done wrong but it doesn’t seem to be working for me.

Thanks

It might be worth while opening a githb issue on the link i sent

Also check your HA logs to see if there is any notification referencing this integration which might point you in the direction of any problems (if you have not done so already)

Good idea … probably do that . Unsure thou what entities it should create , documentation says one for each smart meter … ??

Unfortunatley mine is down at the moment, the IHD they supplied me stopped connecting to my meter. I think they are having some issues as my email bounced on friday, so cant show you it working, however my setup is below.

I only have the electric smart meter (no mains gas where we live) but its basically a single sensor that gives you the data in Watts.

If you wanted to get a bit more fancy I’ve done the following:

  1. Convert data into kW
  2. Get daily cost base on my energy rate
  3. Use the Utility meter integration to track Daily / Monthly / Annual energy use

Yaml for the three things i do i below if youre interested, the standard integration gives me entity sensor.electricity_consumption which i use to get my kW, then build on from that

sensor:
  - platform: integration
    source: sensor.electricity_consumption
    name: house_energy_kwh
    unit_prefix: k
    round: 2
  - platform: template
    sensors:
      daily_energy_cost:
        friendly_name: "Daily energy cost"
        unit_of_measurement: "£"
        value_template: '{{ (states("sensor.daily_energy") | float*0.1654) | round(2) }}'

utility_meter:
  daily_energy:
    source: sensor.house_energy_kwh
    cycle: daily
  monthly_energy:
    source: sensor.house_energy_kwh
    cycle: monthly
  annual_energy:
    source: sensor.house_energy_kwh
    cycle: yearly

Hi

Thank you , really useful just what I had planned to do with these originally to monitor usage, daily and ability to review history.

I logged an issue on github as you suggested so once I hopefully can get the integration working I shall be giving your code a go.

Thank you for taking the time to sent this.

Will post an update as things change … might try another delete and re-install to see this week

Regards

Andy

No issues, and good luck!

Had my Smets2 meters installed this week and still waiting for my IHD to turn up when I found out about Hildebrand. Installed their Bright app and got approved today with data seen in the app.

Added this via HACS this evening and like you I get no sensors shown.

Should this work without purchasing their CAD which will give more frequent updates.

Hi

I thought the same but I can’t see why it would need their display to work via the api.

I have logged an issue on GitHub but I’ve heard nothing… maybe if you log one as well it might get looked at .

I’m not so sure. They want us to buy their CAD otherwise we could just grab the data they give us and just use HA to deal and display.

The Application ID that the integration asks for - is that the ID of your Glow Cad or (b0f1b774-a586-4f72-9edd-27ead8aa7a8d that I grabbed here ?

I just checked their guide and these are the prerequisites so it should work -

Prerequisites
To retrieve data from the API you need to do the following:

  1. Download the Bright App (see instructions below)
  2. Create an account using Bright (sign up following the App instructions)
  3. Set up your data
    a. If you have Glow hardware, set it up (connected to both the meter and the
    internet)
    b. If you have a SMETS 2 smart meter, complete the verification process within the
    Bright App (on first time login) and wait for confirmation via the App and in an
    email that the verification has passed. The verification process is required
    whether you purchase hardware or not. (Hildebrand can retrieve delayed half
    hourly consumption data from the DCC because we are a DCC Other User).
  4. If, in addition to the Glowmarkt API, you would like access to MQTT please do the
    following:
    a. email [email protected] stating that you wish to use the MQTT
    a. provide the Username you used when you created your Bright account and
    b. the MAC ID on your Glow CAD (either the GlowStick or the IHD/CAD)

Using their guide and Postman I can pull my data so it should work

image

Did you get this working ok for you? I have the IHD display showing both my Gas and Electricity usage, however in HA I only have my electricity meter coming in as a sensor.

I bought their CAD and got MQTT enabled. I can now pull in all my usage data into NodeRed and I even work out my daily costs based on the usage and a calculation on the unit cost.

Their CAD is a really nice bit of kit and their support is excellent with the couple of questions I asked them.

image

Are you still getting data through?

I also bought the CAD but didn’t get MQTT enabled. As per my previous post I was recieving data from my Electricity meter but not the gas. Now i’m not receiving anything. The electricity sensor is just showing as unavailable. Are things still working ok for you?

If you want to get all your data then you need to request MQTT access via email.

I did have an outage on my gas earlier tonight on the CAD and MQTT but that is working again now.

I found an excellent GitHub Link about getting the MQTT data into HA. I use NR so it was quick and easy to get at the data and to update a couple of sensors but it is easy enough to add them to a sensor.yaml file.

Thanks for your guidance.

I’ll have a look into getting MQTT setup.

Is anyone using the hildebrand integration through HACS? I’ve added the integration via HACS and restarted but it doesn’t come up as an integration to add and there’s no error in the logs?

1 Like

I was going through just this yesterday. I tried installing it via HACS a couple of times, latterly enabling beta versions and getting the most recent. Initially there was still no integration to setup but after about 45 minutes I checked again and it had appeared as an integration. I was able to add it and add my Bright app login credentials but it reports “failed to setup” and checking the logs I have:

This error originated from a custom integration.

Logger: homeassistant.config_entries
Source: custom_components/hildebrandglow/glow.py:100
Integration: Hildebrand Glow (documentation)
First occurred: 8:29:14 (1 occurrences)
Last logged: 8:29:14

Error setting up entry for hildebrandglow
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 293, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/config/custom_components/hildebrandglow/__init__.py", line 30, in async_setup_entry
    await hass.async_add_executor_job(glow.retrieve_cad_hardwareId)
  File "/usr/local/lib/python3.9/concurrent/futures/thread.py", line 52, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/hildebrandglow/glow.py", line 100, in retrieve_cad_hardwareId
    self.hardwareId = cad["hardwareId"]
KeyError: 'hardwareId'

With the new features in Home Assistant I was hoping to pull in my data from my SMETS2 meter. I don’t mind buying a Glowmarkt device if that’s the key but currently they are out of stock :frowning:

Hi, I’m having the same error, did you manage to resolve it?