History and logbook no longer working

Hello, awhile ago I disabled history and logbook to save space on the sd card. Everything works cool. I did try a few times to re-enable the tools but am not able to. I can not remember what steps I took to disable them, seems to me it was more than just commenting the entries in config.yaml.

Now, I am getting invalid config messages and would like to fix it despite the fact it all still works., I had even done a complete fresh install a few months ago and because I backed up to my old data, of course somehow it still does not work.

The error message I receive is:

Invalid config
The following integrations and platforms could not be set up:


The recorder could not start, please check the log

my config.yaml looks like this: (sorry, formatting/pasting code not doing what it should)

# Configure a default setup of Home Assistant (frontend, api, etc)
  base_url: https://nonsenseblahblahblahyamer.dukcdbbs.org:3218
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ip_ban_enabled: true
  login_attempts_threshold: 4
  customize: !include customize.yaml

default_config includes history and logbook so ha may be confused by the doubling up


thanks for the reply, I did have just default_config (without the logbook and history) before and it still throws the same errors

In addition to Nick’s advice, http: should not be indented below default_config: it should be hard up against the margin.

You have:


It should be:


no, thats not it, makes HA unloadable

It’s part of it.

In addition to Nick’s and my previous advice, please see the documentation. You are using an outdated key, base_url that has been replaced with internal_url and external_url that now both reside under homeassitant:

No base_url in this:

See here for internal and external url:

Thank you for the information , it was not what was needed but I still did benefit by getting the external url corrected.
Updated to 112 and was still not working but I noted that 112 focussed on logbook and history so I did some reserach and lucked out. I located the correct db file, looked into it, nothing there, i deleted it, reboot and Voila, back to normal.

What does a stringed instrument played with a bow have to do with it?

lol, nothing just that i am bad at typing

Hi, I’m getting exactly the same problem. Up to date on versions (I too tried moving to 112 but didn’t help).

I get “invalid config” for recorder, logbook, history and default_config as well as the recorder could not start notification. Just the same as you reported.

Can you let me know how you fixed it? What db file did you delete?


1 Like

There is only 1 db file

ok, worked this out - for others who have same problems, delete the file in the config folder called home-assistant_v2.db

Reboot, all comes back to life (obviously old data is lost - I didn’t care, but if you do, you might want to look for other options!)


The problem must be related to this issue.

1 Like

Glad you worked it out, apologies for not responding, just logged in today to see your query.

Same issue here - renamed the db file (just in case) and after a reboot all good again. No doubt the schema had changed in the previous update - kinda annoying that wasn’t picked up but what the hey. All good now.

1 Like

That did it for me too. Thanks!

1 Like

the file in the config folder called home-assistant_v2.db, there is only 1 .db file

Worked perfectly, deleted the database and the issue is gone. Thanks for posting.

1 Like

Hi and thank-you, it worked for me

Had the same issue.
All is good now.