History Graphs – Not displaying properly / working properly

Tags: #<Tag:0x00007f3266766e08> #<Tag:0x00007f3266766cc8>



After an upgrade I discovered that my History Graphs did not show any history.

  • When I had multiple Entities on a History Graph Chart in Lovelace it would just state “Loading State History”.
  • When I had only one Entity on the History Graph Chart in Lovelace it would just show the initial state and never update the chart.
    Restoring from an older Snapshot did not help. It appears that the “home-assistant-v2.db” was corrupt.
    Delete the “home-assistant-v2.db” file in the “config” folder. Same folder as “configuration.yaml”. History works properly after a restart.
    Thank you to @AgNasty (https://community.home-assistant.io/t/history-graphs-not-displaying-properly/205057) for guiding me in the right direction.

I don’t understand, is this solved now? If so, please close the topic.

It’s solved now. I wanted to share with others who might experience something similar. I’ll figure out now how to close the the topic. Thx @Burningstone