History just spins. Sort of solved

[I’m putting this here because googling showed me other people were having trouble with this but I didn’t see a decent answer anywhere.]

While debugging some automations and a new component/switch/sensor that I wrote, I found myself unable to reliably get the History to graph properly, as well, I was unable to get individual graphs when clicking on a sensor. The spinner wouldn’t stop, it just kept spinning.

I spent a little bit of time debugging the problem and discovered the problem is not with homeassistant. The graphing of the history is done by Google Graphs.

I was able to retrieve the history successfully from homeassistant by doing /history/period which told me the data was there and homeassistant was able to retrieve it. That meant the problem had to be in my browser when passing the JSON to Google for graphing. I turned on the debug console and saw this:

Uncaught (in promise) DOMException: Only secure origins are allowed. Prefer Secure Origins For Powerful New Features
frontend-a7d4cb8260e8094342b5bd8c36c4bf5b.html:1 HTML element is ignored in shadow tree.

As I am not a web-developer type, I’m not sure how to fix this problem. But it’s possible there’s something wrong with my Chrome installation as it works fine with Safari (how ironic)…

1 Like

You led to me my fix: I too had the History showing the spinner continuously (in Chrome). Your post mentioned favorable results with Safari. I tried Edge and their was no issue. I cleared the cache in Chrome and things were resolved.