History not working after latest update

Since the latest update, at least. I’ve not been able to load any history for most of my useful entities. some things like helpers seem to work, but the climate, and other values do not work at all.

I’ve dropped the entire homeassistant database and rebooted so it would be recreated. The logbook seems to work, but I’m still seeing the same behavior, simple entities are showing a history since the reset, but everything else is broken.

I’m using mariadb for my database

is not a version

Home Assistant Core 2022.6.2

Home Assistant Supervisor 2022.05.3

Home Assistant OS 8.1

I suspect this started with 2022.6.0

Mine is all good.

On the 2022.6 betas and 2022.6.0 I saw very slow performance from logbook, it seemed to be fixed in 2022.6.1 and still OK in 2022.6.2. I too am using mariadb.

Anything in the mariadb or HA logs?

No errors in the addon log, and no mention of mysql in the logs other than when the recorder starts up.

Well that sucks that I lost all my history. It turned out to be a browser issue. Turning off brave shields (even though I have them turned off in settings) allowed the history to display.
Thanks for confirming there’s not a known new issue

Did you back up your db before deleting it?

Since I updated to 2022.6.2 four days ago, I see the same problem with missing entities.
Some information:

  • I can still see all entities in Home Assistant.
  • In previous versions all entities went directly into mysql database
  • e.g. entities from Homematic are still working
  • e.g. entities from openweather are (desperately) missing since version 2022.6.2
  • all entities from sensors.yaml are missing
  • I haven’t made the update 2022.6.0 and 2022.6.1

I suspect the new performance things for the sql-database. Is it possible that some entities are disabled by default to write the status into the database?
Can this be configured?

Your issue is unrelated, my problem was the history views weren’t loading in the Brave browser with the “shields” feature active on my homeassistant page.

You should consider removing and readding openweather. Disabled entities are still visible, but if the integration doesn’t initialize correctly, the entities will disappear. make sure your sensors.yaml passes the configuration check and is included properly. Try moving the config into configuration.yaml to confirm this.

This is still a problem. I’ve just updated to 2022.8.1 and still my history is not showing. That’s the history main menu item which just does nothing; just a loading circle"

With the “History Card” I get “Loading state history” for all sensors. The data is in the database and can be accessed with “History Explorer Card”.

The browser console shows this error, which is a problem but I suspect is not the cause:

Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'substr')
    at i (typography.js:181:1)
    at n (e68243ce.js:1:665)
    at state-history-charts.ts:17:1
    at state-history-charts.ts:17:1
    at Array.map (<anonymous>)
    at h (state-history-charts.ts:17:1)
    at ha-circular-progress.ts:7:1
    at async HTMLElement.value (hui-history-graph-card.ts:131:1)

Replacing the database, the browser etc have no effect. Do other people see this problem? Any further suggestions as to what I can do?

Make sure if you’re using a different database, like mariaDB, that it is running. I found that mine didnt automatically start after updating to 2022.8.

Thanks, but yes, it’s running. It has been since May. It works, has the data recorded and it can be accessed by HA. I’ve tried changing back to the standard db but it makes no difference.

The only thing I haven’t mentioned is that I’m using the docker version of home assistant.

Yes, I am also seeing this. running HA OS 7.6 on a PI 4 , Core 2022.5.5. I’m holding off going to 8.5 as I’m afraid of what else might break. Still looking for a solution, but let me look more into the database suggestions posted before me. One thing to note - the “Statistics Graph Card” works just fine and hasn’t broken. But the simple “History Graph Card” is broken all my history graphs.

I took the plunge/chance and upgraded to 8.5. Graphs are back and working.

I’m on 9.2 and it still doesn’t work. I’m using History Explorer card which works but is a bit overkill for my needs.

I don’t understand why there’s not more noise about this - i.e not many users having trouble.

I use the docker image; maybe there’s something wrong with it.

Have you posted an issue to github? If not, do so.

I finally succumbed: