Hive heating with ZHA - no auto mode

Hi experts,
I am using Hive heating with ZHA integration (no hub), which works very well so far.
But it looks like there is no ‘auto’ mode, only heating and off.

the problem is that if I change the target temperature either manually or with an automation, for example to boost the temperate or switch off if I go out.
there is no way to switch the target temperature back to what it was before charging it.
When I was using the custom integration with the hub, I could call the ‘HVAC mode Auto’.

I guess one option would be to first take a snapshot of the entity before making the change and then load the snapshot to put it back.
This would address if changed with an automation, but not if I change manually.
It would also be a problem if the schedule changes between taking and loading the snapshot.

Does anyone else have this issue or have any suggestions?