Home App will not find Homekit on Home Assistant

Tags: #<Tag:0x00007f7396db6ee0>

I have looked at multiple threads and even asked some community members in those threads if they found the solution but so far I’m still stuck. I’ve also noticed a lot of the threads on this topic are dated or more geared toward RPi or Hass.io.

Here is my issue, I set up Homekit in Home Assistant, I get the pairing code when I restart HA but my Home App on my phone never finds HA and entering the pairing code manually just spins. I have logged out of iCloud, deleted the Home App, and restarted my phone (multiple times).

Here is what I’m working with:
Home Assistant - 0.103.6
It is in Docker on my Synology DS918+ running DSM 6.2.2-24922 Update 4
I have a Unifi USG, switch, and APs - they are 5.12.35
I have a RaspberPi running Pi-Hole attached to the switch that all network traffic travels though.
iPhone X running - iOS: 13.3
AppleTV running - tvOS: 13.3
I do have the Synology firewall turned on but I have tried it off and opened TCP ports 51827, 5353, 8123

My Synology is on Ethernet with an IP of 10.1.1.#
My iPhone is on WiFi with an IP of 10.1.1.#
My AppleTV is on Ethernet with an IP of 10.1.1.#

I recently rebuilt my Home Assistant config file so currently I’m just using:

homekit:

I have tried:

homekit:
  filter:
    include_entities:
      - demo.demo

and

homekit:
  safe_mode: true

and

homekit:
  advertise_ip: "STATIC_IP_OF_YOUR_DOCKER_HOST"

I’ve also deleted the .homekit.state file and restarted, multiple times. I’ve also tried a Mac plugged into the same Unifi switch as the Synology (you can’t add accessories in home on a Mac). I never had home bridge so I shouldn’t have a conflict there.

I feel like I’ve gone down the entire component page at home-assistant.io and tried all of the possible fixes. I am definitely a N00B at this, YouTube is my friend.

Any help would be greatly appreciated.

Same issue. Same basic setup (Synology running Hass.io in docker). I’m running the latest version (0.107.1). I’m also using AppleTV and have a Unifi controller running in another docker container. It was working great for me before I moved to the Synology, which makes me think it has to be a firewall or port issue. Did you happen to figure it out?

I do have HomeKit working now but can’t remember at this time how I got it to work. I’ll take a look at my config when I get home later.

Figured it out. It was my vpn. When I turn it off, all homekit accessories immediately start responding again. Sorry for the noob question–it should have been obvious. I really appreciate your quick response!

In the Unifi Controller Settings make sure that “Auto Optimise Network” is turned off as this blocks mDNS which HomeKit needs to work.

This worked for me.