Home assistant Access blocked from egypt

Hello i have an issue with home assistant supervisor which blocked from downloading addons. Also, i can’t access home assistant website or community website. i used a VPN to access the website So is the Home assistant is blocked in some countries ? i am accessing from Egypt

1 Like

That can be and by the looks of it is true for your provider in egypt. It’s not necessary that all ISP in one country do the same so sometimes other providers don’t (over)block. :lock:

In general there is little HA can do actually. :man_shrugging:

For you as a citizen of a country which censors free internet access you can work’a’round it with technologies like TOR or VPN. Also you can use tools to actually measure the “level” of censorship :stop_sign:

For example you can make use of the “Open Observatory of Network Interference (OONI)” (they have Apps for phone and computer) :point_down:

You can also read about the egypt internet censorship here:

And actually see sites that are blocked/accessible from user tests:

Did you find a solution to connect to supervisor ?

Facing the exact same problem. Why these Egyptian assholes all of a sudden started blocking the HASS sites, only Allah knows …
Anyway, circumventing the site’s block can be done with a VPN, but that does not help to get hold of updates, etc :frowning:


Thank you all for your replies.
But the issue now how to update and install addons and system updates???
this is a critical issue

The same problem happened with me about a week ago and the problem was solved by using VPN.
I am from Egypt and I use internet from Etisalat.com.
But what is the main problem? and is there a solution ?

Your government’s overzealous attempts to censor the Internet.


Can I use Duckdns with a port other than 443

www.home-assistant.io TCP/IP blocking in Egypt

Solved by VPN but I wish to know why they blocked it

could you please explain how you solved by VPN?
I am using VPN software and I configured the VM to work as network bridge, which mean the IP address obtained from router is blocked, and if change network config to NAT, the Home assistant doesn’t work!
could you please advice!

HA can provide a .onion domain.

Let me clarify : the problem of accessing the HASS site & forum is rather easily dealt with using a VPN and such.
HOWEVER : the bigger and as far as I know still unsolved problem is that our HASS system also no longer has access to these sites, and therefore is totally cut off from updates, etc. It no longer is aware of them, and even cannot install the ones it saw just before the ban became active.
A (hopefully temporary) fix would be for us to be able to download the necessary files, and a way to then ‘manually’ update our systems, bypassing the supervisor’s block because of the missing connection. Any pointers ?

thats the other way around.

Yeah, sorry. I realised that after I posted it. I’ve contacted the project leader to see if they can do anything.

Actually that wouldn’t make much of a difference for people living in egypt. They can already make use of TOR or VPN today to overcome the censorship (despite it is a .onion domain or not) :bulb:

If HA would be available via .onion domain people would still need to make use of TOR to get access :man_shrugging:

How is this shown in the supervisor log?

Does it help to change the DNS to

kindly let me clarify 2 points
access Home assistant website and Home assistant community could be solved by using VPN software on the machine which is running VM or using Tor browser.
but installing Home assistant and installing updates or add-on from HS store can not be done due to the configuration of bridge on the VM ware, because it’s take its IP address from the local router which is blocked by default from the Egyptian government.
I tried to use NAT config in the VM, but it didn’t work, i don’t know why!

Any Ideas?

All sorts of ‘CheckDNSServer.run_check’ blocked from execution, no supervisor internet connection’ and similar messages. The supervisor suffers from the dreaded ‘connectivity limited’ syndrome, although I fear this is just the first hurdle it encounters, with more to follow once it gets over that …
And alas, changing the DNS server does not help at all - I previously tried with, but that shouldn’t matter. I’m afraid the egyptians’ blocking tricks are more sophisticated than that :frowning:

I found a few threads on the cloudflare forums that indicated that switching to (even from would help in some cases.