Home Assistant Add-on: Samsung the Frame art Changer

I’ve created a new add-on It adds the ability to place images in “Media” (it creates a specific directory for it under MyMedia called “TheFrame” where you can place your images).
And then it Will randomly push a picture to your Samsung the frame!
Please find it at GitHub - gijsvdhoven/home-asssistant-samsung-frame-art: A small script that makes it easy to fling a folder of images onto the Samsung Frame TV

2 Likes

How is the add-on supposed to work? I have set the IP and started the add-on but not sure how to play the art work. Should it start automatically or are the files transferred to the TV? I have a 2023 Frame. Thanks in advance

I installed the AddOn and copied some photos to the new created folder „frame“. The AddOn fires an error (see attachment). What may be the problem?

Are you using the correct file extension? It can be picky. You must upload pictures with a lower-case extension and only .png and .jpg

Hey @Gijs_van_den_Hoven looks like I get an error when trying to upload an image. Any idea? Screenshot of logs uploaded.

Installation seemingly went fine (no errors), but running “Call Service” doesn’t seem to do anything.

Again, no errors. Just…nothing happens.

Hi, is the addon still working?

Hmm weird… should be the picture then I guess

It just starts, does it thing, and them exits. Nothing visual happens in HA, just in the logs

Does at my place!

It just starts, changes the picture and then exits. It picks a random picture from the created picture in “media”

How is this different from setting the frame to randomly pick a picture from the ‘my photos’ directory on the TV every 24 hours? Trying to work out how this might fit in to my own automations.

What I would find useful is an addon that leverages the Frame’s art mode to dynamically display a dashboard, certain entity statuses and alike.

Got this installed correctly. But the problem that I have is that whenever I upload an item to the frame directory, I get the message: “1 incompatible item hidden”. I followed the directions in the thread to only use .jpg and lowercase files. Any suggestions?

Figured it out! Had to change drop down option in lower right hand corner when viewing directory to “Web Browser”. Now everything works! Well done!