Home Assistant addon : qbittorrent (supports openvpn & smb mounts)

Just a little problem: I’ve installed Portainer and found that I’ve a LOT of version of Qbittorrent addons images, taking up a lot of space on my SD card. It seems that when upgrading, they’re not uninstalled/Deleted .

1 Like

Thanks, I had the same… 30go of unused images from various addons… However I believe this is an HA issue I’m not sure what can be done from the addon side. The issue is that it is updated very frequently as it is kept aligned with the upstream images and that HA seems to keep a lot of residual images.

The solution is to run “docker image prune - a - f” in the Web terminal addon to remove all those unused images… It is an issue that seems to exist since 2017 Unused containers/images not deleted by hass.io, and regularly highlighted like here a few weeks ago… No space :( - #19 by alexbelgium

If someone has a solution I would be very happy to implement it!

2 Likes

Hey Alex

After enabled OpenVPN at qbittorrent, i cant access WebUI outside of my local network, only inside with IP:PORT . If i disable openvpn i have access at WebUI inside and outside at my local network
And, im not changing any port mapping that i have in my router…!

I received this error at internet browser:
“ERR_TUNNEL_CONNECTION_FAILED”

Can you help me with this? Thank you!

Hi Wilson,

I would need some additional info to help troubleshoot.

The normal behavior is that webUI is only available from within the local network through HA_IP:ADDONPORT/ (as the port is normally not exposed by the router, unless you specify it specifically), but Ingress is available both from internal and external network (in the HA app).

  • Which one is impacted by openVPN addition, the Ingress one ?
  • Could you please provide any messages in your addon log when the issue occur ? (connection failures issues should appear)
  • Have you tried with/without ssl ?
  • Does this occur with all devices / browsers ? I know that some browsers can cause specific issues (microsoft edge prevents ingress working on my computer for some reason, other browsers work)

Thanks

Ok, i will show you with more information:

i have in my router a PORT FORWARDING redirect external port 8081 to local IP_of_HA:8081
in my config yaml i have this (i’ve tried with and without ssl):

  1. when i have OpenVPN Disabled:
  • i can access localy, at browser with IP:8081 or at Ingress HA.
  • and remotly with myddns:8081
  1. when i have OpenVPN Enabled
  • i can acCess localy, at browser with IP:8081 or at Ingress HA.
  • but, I CANT ACCESS remotly with myddns:8081 and i receive an error at browser tell me this: " ERR_TUNNEL_CONNECTION_FAILED

In log, i cant find an error to explain this, but i think is related with tuneling, because i dont have this problem without VPN in last months.

LOG WITHOUT VPN:

LOG WITH VPN:

I hope this additional information can help to troubleshooting.
Thks

1 Like

Actually this is normal behavior… When we implemented openvpn with Milenco, we had to route specific IP to allow bypassing VPN to connect to the webUI. We routed most universally used local networks, but it is not possible to route all external IP…

I see three possibilities here :

  • either using Ingress to access the webUI from external networks (meaning that only the 8123 HA port is exposed, and that qBittorrent is managed from the HA app)
  • that I add an option in the addon so that we can specify some external IP that can access the webUI and bypass the VPN
  • or that I rewrite the VPN to only tunnel qbittorrent and not the webUI. This is not a preferred option as people have reported (like here)that it throttles qbittorrent speeds and decreases torrenting stability…

@wilsonlspacheco Another idea : if you add “route-nopull” at the end of your openvpn config file, it will prevent this behavior. But you then need to go in the qbittorrent options and select tun0 as network interface in the advanced options to allow openvpn to tunnel qbittorrent. Then, you’ll achieve locally what I described in my option 3 above. If you confirm it works, I’ll create a boolean option to activate this automatically (alternate openvpn connection method). Thanks!

1 Like

Hey @alexbelgium, sorry for my late reply…! I tried this your last suggestion/idea, add “route-nopull” to my .ovpn file and change connection in Advanced Options to “tun0”, and now i can access to my qbittorrent remotly ! This is the best solutions ! Many Thks! you are the best ! :smiley: :facepunch:

1 Like

Perfect! Thanks for the feedback. I’ll add this as an option so everyone can use that if necessary

1 Like

@wilsonlspacheco

New version : 14.3.5.99202105022253-7365-063844ed4ubuntu20.04.1-ls133-dev2

New feature : option openvpn_alternative_mode added. This boolean activates an alternative openvpn connection mode that binds only qbittorrent but not the webui to the vpn. This is allows to reach webui from an external network (thanks @wilsonlspacheco for testing!) but there is a slight risk of decreased performance. Please let me know if this should be the default, instead of the alternative.

1 Like

No problem @alexbelgium, my pleasure ! :smiley: :facepunch:

1 Like

Hello! Ive got problems finding my mounted directory. In my logs it says
[21:49:12] INFO: … //192.168.1.xxx/Seagate successfully mounted to /mnt/Seagate with options

But when i use terminal and cd into/mnt and do ”ls -a” There is nothing?

What am i missing?

1 Like

Hi, this is a normal behavior due to how docker works. Mounted folders are only mounted in the container - the terminal is in a separate container (of the host). However, if you install portainer, you can have a console inside the container and see the mounted folder.

That’s why each of my addon has a separate mount option for smb drives.

@adamoutler has another solution : an addon that can execute the mount code at addon startup : see here ✔️🏃Run On Startup.d

So if you don’t log in the container with ssh or portainer, you need to trust it to work and go see in your smb disk files appearing after download.

Need help. I cant enable incomplete folder. Whenever I check “Keep incomplete torrenet in” and save. It become uncheck the next time. It also greyed out on the path field.
What is the work around ?
Nothing on the logs, I dont use network mount.

@tyjtyj Hi! That’s strange, I have this option enabled and it works fine, including changing it from the UI… Do you use the latest version of the addon? (at one point I had added temp folder mgt in addon options, but removed it afterwards)

Some options :

  • you can try setting PUID / GUID to 0 and 0 in addon options (perhaps I made a permission issue)
  • you can try to set it manually by editing the qbittorrent.conf file in /config/qBittorrent /qBittorrent.conf and add
Downloads\TempPath=/data/incomplete/
Downloads\TempPathEnabled=true

Thanks !

And have you checked that the folder exists also?

Thanks!

Hi, one last thing : actually I’ve tested again and noticed there is a bug in the alternative webui VueTorrent. Are you using it?

Enabling or Disabling the option in VueTorrent seems to work (as can be checked with the flag in /config/qBittorrent/qBittorrent.conf Downloads\TempPathEnabled=true that goes from true to false) but it remains unchecked in VueTorrent webui.

If you disable VueTorrent (last tab in VueTorrent options), the normal ui seem to correctly show the incomplete folder info

Managed to edit the config file and restart. it seems to work although it still grey out

I will leave it as it is as i dont change this often

1 Like

More questions
Ingress hardcoded to vuetorrent UI ?
If i go by ip, i get original qt ui.
if i go by hass ingress, i got vuetorrent web UI

Custom UI set to blank.

Where do I set de webui password ? (and remove the default admin user)