Home assistant app suddenly stops working after setting it up

I recently setted up home assistant I use an old laptop for the os and when trying to use the app with my phone connected to my house wifi to connect I’m unable to do so . I have to clear the app storage and reinstall it after a while and then it stops again after a couple of minutes. Keep in mind I can connect fine with my laptop and my brothers phone with the same exact url (The default not a duckdns one). I have searched around and I can’t seem to find any solutions.I have a non rooted Poco x3 pro phone with an unlocked bootloader while my laptop run windows ten and my brothers phone is stock Xiaomi. Can anyone help?

I did saw the docs but I wasn’t able to find any help to my particular issues since I’m new and don’t understand all the terms mentioned I’m might have missed something. Would you be able to pin point me to the right direction?

Did you download and look at the companion app android logs from your phone (as recommended in the link above)?

Did you examine the logs in Home Assistant?

When looking at the mobile app logs I found this error
01-04 14:33:22.916 8359 8359 D IntegrationRepository: isAppLocked(): false. (LockEnabled: false, appActive: false, expireMillis: 1704371048887, currentMillis: 1704371602916)
01-04 14:33:22.940 8359 12545 E OpenGLRenderer: Unable to match the desired swap behavior.
01-04 14:33:22.978 8359 8359 D IntegrationRepository: isAppLocked(): false. (LockEnabled: false, appActive: false, expireMillis: 1704371048887, currentMillis: 1704371602978)
01-04 14:33:22.978 8359 8359 D IntegrationRepository: setAppActive(): true
01-04 14:33:28.117 8359 8406 D LogcatReader: Read logcat for pid 8359

Regarding the logs in home assistant I’m not sure if I should be looking at the DNS ones but here is what I found
s6irc: info: service sorc-oneshot-runner: starting

s6 rc: Info: service sérc-oneshot-runner successfully started

src: info: service fix-attrs: starting

90-rc: info: service fix-attrs successfully started

sb-rc: info: service legacy-cont-init: starting

cont-init: info: running /etc/cont-init.d/corefile.sh

cont-init: info: /etc/cont-init.d/corefile.sh exited o

so-rc: info: service legacy-cont-init successfully started

s6-rc: info: service legacy-services: starting

services-up: info: copying legacy longrun coredns (no readiness notification)

s6-rc: info: service legacy-services successfully started

[ERROR] plugin/adns: could not locate primary interface due to: Could not resolve, server or network returned error SERVFAIL




linux/amd64, go1.15.15, 053c4d5-dirty

The situation is really bizarre because I can’t really find what makes the app stop working it just randomly happens and then works again after a while . I also tried opening the location of my phone and while I get a notification saying I’m connected the app the app doesn’t work and I get a new set of errors and since I can’t really type all the characters because of the characters limit and I don’t see an option to add a file here is a we transfer link WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

The screenshot shows a network error. Have you restarted/reset your router? Does your phone have all the latest system apps (Android System WebView)?

Is there anything in the Home Assistant Supervisor Log that matches the time of the error you are seeing on your phone?

The home supervisor log has zero errors
I did restart my router and now I all the devices I have are unavailable

I think you have a problem with your network - not Home Assistant.

They were unavailable because they changed ip but still how does a problem in my network only affect one device the app just stops connecting and needs to be reinstalled . I’m desperate for any solution.

If the DNS cache of the router has a corrupt DNS entry for your device that may cause the problem. It appears to be device/network specific problem since the screenshot indicates a network connection error.

You did say your brother’s phone works fine so it is not the companion app or home assistant.

The only other thing I can recommend is checking all the Android System settings AND the home assistant companion app settings between your brother’s phone and your phone.

EDIT: have you tried these instructions to start fresh?: Troubleshooting | Home Assistant Companion Docs

I can’t thank you enough for being so helpful but the problem was just the battery saver in my phone I hadn’t turned no restrictions on(I will wait a day to make sure that was it and mark it as solved )