Home Assistant Aqara wireless switch Homekit integration

Tags: #<Tag:0x00007f73946dec50> #<Tag:0x00007f73946de7a0> #<Tag:0x00007f73946de6b0>

I have an Aqara hub connected through homekit integration with HA with many devices working fine. I have two wireless, 2 buttons, wall switches: https://www.aqara.com/us/wireless_remote_switch.html
HA sees them, and it made a battery instance for each that is working ok. Yet there is no other instance so I cannot read states from it. I tried subscribing to the state-changed event and took a pick while I pressed buttons. Nothing.

In MiHome App I can watch for click left, click right, double click left, long click left, click both. Neither of these gestures is available for me.

There will be no entity for the state, instead button presses will be events. Listen to all events with * and press a button, the event will be something like xiaomi_event or homekit_event.

1 Like

Thanks for your help!

I tried that, subscribed to *, and didn’t see any event.

I have a list of aviable events in a right panel on the events section. There is no xiaomi or homekit instance there.

I installed homeassistant manually using pip so I’m guessing it could be a matter of missing packages. I’m going to research that now.

I see now that wireless switches like the one you use are not support yet through homekit, but the support should come soon see this post/topis

1 Like

Ok, thanks. You saved me a lot of time.
I guess for now I can manage to make automatizations in MiHome, as I used to do.
I’m waiting for a CC-2531 to arrive soon. If I pair the switch directly to HA, will I have the events working?

Yes, they will work this way.

1 Like

Awesome. Looking forward then.

Thanks so much for your help, and the speed!, it was like googling!. :slight_smile:

2 Likes